summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-20 09:34:02 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-20 09:47:17 +0200
commit0aebbd4c20a64525bca626e6efcdbab4e55728f5 (patch)
tree64de942544040b58237d6392f2fe78441ec1cc48 /dev-python/secretstorage
parentdev-python/google-api-python-client: Bump to 2.45.0 (diff)
downloadgentoo-0aebbd4c20a64525bca626e6efcdbab4e55728f5.tar.gz
gentoo-0aebbd4c20a64525bca626e6efcdbab4e55728f5.tar.bz2
gentoo-0aebbd4c20a64525bca626e6efcdbab4e55728f5.zip
dev-python/secretstorage: Bump to 3.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/secretstorage')
-rw-r--r--dev-python/secretstorage/Manifest1
-rw-r--r--dev-python/secretstorage/secretstorage-3.3.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/secretstorage/Manifest b/dev-python/secretstorage/Manifest
index 5e3b4b0f85c8..936689d80892 100644
--- a/dev-python/secretstorage/Manifest
+++ b/dev-python/secretstorage/Manifest
@@ -1 +1,2 @@
DIST SecretStorage-3.3.1.tar.gz 19566 BLAKE2B 0b1ab822ee29f3d56148b558b3029fd882f1d10ceb3e026586de2e9bc72b7ac1b35df11052117a7c07524ca72d004ef56d99c845bc3600984fe84e5300f3dfee SHA512 5e874d08c9e00626a217db96b131884daf92429a91f690b32f62052747275ad0effbe2b4abe048e67fe7f81df97507f8375408898ff986e6f883b5fdfbf2a76c
+DIST SecretStorage-3.3.2.tar.gz 19285 BLAKE2B 17089e61a9549f4547faa8c6f7f711f5e4b3ba9ac0bf7787c3384d4920c5cd02704bab86fd4b7abe4ad9b93098b1668cf89901f4a0760023e274c8daf009d5a4 SHA512 f04a35925f86fec25435554083ac0d4b21b88cbc19b67a4c744247e659bc767675a52d18b33be557e99593922aecb0c261ec40803c61e089ff35b6c8b541ac63
diff --git a/dev-python/secretstorage/secretstorage-3.3.2.ebuild b/dev-python/secretstorage/secretstorage-3.3.2.ebuild
new file mode 100644
index 000000000000..25280f6334e9
--- /dev/null
+++ b/dev-python/secretstorage/secretstorage-3.3.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+MY_PN="SecretStorage"
+
+DESCRIPTION="Python bindings to FreeDesktop.org Secret Service API"
+HOMEPAGE="
+ https://github.com/mitya57/secretstorage/
+ https://pypi.org/project/SecretStorage/
+"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/jeepney-0.6[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ !hppa? ( !sparc? (
+ gnome-base/gnome-keyring
+ sys-apps/dbus
+ )
+ ) )
+"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx docs \
+ dev-python/alabaster
+
+src_test() {
+ case ${ARCH} in
+ hppa|sparc)
+ einfo "gnome-keyring is not supported on ${ARCH}, skipping tests"
+ return
+ ;;
+ esac
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ dbus-run-session "${EPYTHON}" -m unittest discover -v -s tests \
+ || die "tests failed with ${EPYTHON}"
+}