summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-01-07 20:37:24 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-01-07 20:37:24 +0100
commit950107677e7ab5383ddce4622c720036dbfad586 (patch)
tree86f71e9f4572cdd4541bdcfe29805c6b21ca2cc3 /dev-python/rfc3987/rfc3987-1.3.8.ebuild
parentdev-python/simplekv: bump to 0.11.11 (diff)
downloadgentoo-950107677e7ab5383ddce4622c720036dbfad586.tar.gz
gentoo-950107677e7ab5383ddce4622c720036dbfad586.tar.bz2
gentoo-950107677e7ab5383ddce4622c720036dbfad586.zip
dev-python/rfc3987: bump to 1.3.8
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-python/rfc3987/rfc3987-1.3.8.ebuild')
-rw-r--r--dev-python/rfc3987/rfc3987-1.3.8.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/rfc3987/rfc3987-1.3.8.ebuild b/dev-python/rfc3987/rfc3987-1.3.8.ebuild
new file mode 100644
index 000000000000..7e5f142779dc
--- /dev/null
+++ b/dev-python/rfc3987/rfc3987-1.3.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Parsing and validation of URIs (RFC 3986) and IRIs (RFC 3987)"
+HOMEPAGE="https://github.com/dgerber/rfc3987 https://pypi.org/project/rfc3987/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="$(python_gen_cond_dep \
+ 'dev-python/regex[${PYTHON_USEDEP}]' python2_7 'python3*' pypy)"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ ${EPYTHON} -m doctest -v "${S}/${PN}.py" || die
+}