summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-10-05 16:15:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-10-05 16:24:11 +0200
commit8be9f4fed9fb931b9ca71eb586bd4f4809c8072a (patch)
tree5fa8416e5528815037d38a4a90d10db3e7e77fa4 /dev-python/rfc3987/rfc3987-1.3.7.ebuild
parentsys-boot/grub: Install an example grub.cfg (diff)
downloadgentoo-8be9f4fed9fb931b9ca71eb586bd4f4809c8072a.tar.gz
gentoo-8be9f4fed9fb931b9ca71eb586bd4f4809c8072a.tar.bz2
gentoo-8be9f4fed9fb931b9ca71eb586bd4f4809c8072a.zip
dev-python/rfc3987: bump to 1.3.7
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-python/rfc3987/rfc3987-1.3.7.ebuild')
-rw-r--r--dev-python/rfc3987/rfc3987-1.3.7.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/rfc3987/rfc3987-1.3.7.ebuild b/dev-python/rfc3987/rfc3987-1.3.7.ebuild
new file mode 100644
index 000000000000..75bdda89b090
--- /dev/null
+++ b/dev-python/rfc3987/rfc3987-1.3.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Parsing and validation of URIs (RFC 3986) and IRIs (RFC 3987)"
+HOMEPAGE="https://github.com/dgerber/rfc3987 http://pypi.python.org/pypi/rfc3987"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-python/regex[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ ${EPYTHON} -m doctest -v "${S}/${PN}.py" || die
+}