summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-11-28 12:04:56 +0100
committerMarek Szuba <marecki@gentoo.org>2021-11-28 13:05:59 +0100
commita819b856361adae9c2ff9c5f6892760a679c10b4 (patch)
treed73bfe34ffee306bd9b526cebf5155f1e0c910d5 /dev-python/requests-credssp
parentdev-python/pyspnego: keyword 0.3.1 for ~riscv (diff)
downloadgentoo-a819b856361adae9c2ff9c5f6892760a679c10b4.tar.gz
gentoo-a819b856361adae9c2ff9c5f6892760a679c10b4.tar.bz2
gentoo-a819b856361adae9c2ff9c5f6892760a679c10b4.zip
dev-python/requests-credssp: add 1.3.0, remove 1.2.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/requests-credssp')
-rw-r--r--dev-python/requests-credssp/Manifest2
-rw-r--r--dev-python/requests-credssp/requests-credssp-1.2.0.ebuild28
-rw-r--r--dev-python/requests-credssp/requests-credssp-1.3.0.ebuild24
3 files changed, 25 insertions, 29 deletions
diff --git a/dev-python/requests-credssp/Manifest b/dev-python/requests-credssp/Manifest
index ca9270fbf0a4..05c5d94c1dc9 100644
--- a/dev-python/requests-credssp/Manifest
+++ b/dev-python/requests-credssp/Manifest
@@ -1 +1 @@
-DIST requests-credssp-1.2.0.gh.tar.gz 23310 BLAKE2B 647dff76fbb47b9b972f403a9fb2a10ffab5e1915e32977e65b5f5c1cb206ec1b9fa884e12d687761087b2f7f4cb9e8bde631b68140cc50dbd9561a4999bdf55 SHA512 55458773cbf14a468d22d0b04186611385ff24fceda85052e69981bd6d4fd32a46f96b95fa36724b72fd9719485b2ed8906d1927284157e7bc685c0c42c2312c
+DIST requests-credssp-1.3.0.tar.gz 23666 BLAKE2B 3ab7db4c06a65483b26012b282a85174a50c9e9449fc33b90a22f7963bcd33c2b4642ce83f0632383e8c1fbc8dd4761fc00bc6d1adccb5cee020f0d67971f225 SHA512 6281ecd5d7e14792bd175603dfbb95237b990d5cad6e4c7252fd503b76c579590217194ecd3eb3120cb33cc4f2958be459e63fa3fa8d7411a8aa40d1666276b7
diff --git a/dev-python/requests-credssp/requests-credssp-1.2.0.ebuild b/dev-python/requests-credssp/requests-credssp-1.2.0.ebuild
deleted file mode 100644
index b5d40075cda3..000000000000
--- a/dev-python/requests-credssp/requests-credssp-1.2.0.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="HTTPS CredSSP authentication with the requests library"
-HOMEPAGE="https://pypi.org/project/requests-credssp/"
-# .gh for tests in github tarball, drop ".gh" on next bump
-SRC_URI="https://github.com/jborean93/requests-credssp/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv"
-# Needs unpackaged pyspnego (https://github.com/jborean93/pyspnego)
-RESTRICT="test"
-
-RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/ntlm-auth[${PYTHON_USEDEP}]
- dev-python/pyasn1[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-#distutils_enable_tests pytest
diff --git a/dev-python/requests-credssp/requests-credssp-1.3.0.ebuild b/dev-python/requests-credssp/requests-credssp-1.3.0.ebuild
new file mode 100644
index 000000000000..73883daf58cb
--- /dev/null
+++ b/dev-python/requests-credssp/requests-credssp-1.3.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTPS CredSSP authentication with the requests library"
+HOMEPAGE="https://pypi.org/project/requests-credssp/ https://github.com/jborean93/requests-credssp"
+SRC_URI="https://github.com/jborean93/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-16.0.0[${PYTHON_USEDEP}]
+ dev-python/pyspnego[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest