summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-10-14 01:03:10 +0200
committerMichał Górny <mgorny@gentoo.org>2015-10-14 08:06:35 +0200
commit5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f (patch)
treef2de3644b75e298ceeaed790daab2aa73e57d62f /dev-python/redis-py
parentdev-python/setuptools: Partially restore ~arch keywords (diff)
downloadgentoo-5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f.tar.gz
gentoo-5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f.tar.bz2
gentoo-5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f.zip
dev-python/*: Restore keywords and un-revbump for py3.5
Restore keywords that were removed unnecessarily, and collapse unnecessary revbumps on packages with added python3.5 support.
Diffstat (limited to 'dev-python/redis-py')
-rw-r--r--dev-python/redis-py/redis-py-2.10.3-r1.ebuild62
-rw-r--r--dev-python/redis-py/redis-py-2.10.3.ebuild9
2 files changed, 1 insertions, 70 deletions
diff --git a/dev-python/redis-py/redis-py-2.10.3-r1.ebuild b/dev-python/redis-py/redis-py-2.10.3-r1.ebuild
deleted file mode 100644
index 3a78bd4533cc..000000000000
--- a/dev-python/redis-py/redis-py-2.10.3-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
-
-inherit distutils-r1
-
-MY_PN="redis"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Python client for Redis key-value store"
-HOMEPAGE="https://github.com/andymccurdy/redis-py"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-db/redis
- >=dev-python/pytest-2.5.0[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- # Make sure that tests will be used from BUILD_DIR rather than cwd.
- mv tests tests-hidden || die
-
- # Correct local import patch syntax
- sed -e 's:from .conftest:from conftest:' \
- -i tests-hidden/{test_connection_pool.py,test_commands.py,test_encoding.py,test_pubsub.py} \
- || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- distutils-r1_python_compile
-
- if use test; then
- cp -r tests-hidden "${BUILD_DIR}"/tests || die
- fi
-}
-
-python_test() {
- local sock="${T}/redis.sock"
-
- "${EPREFIX}/usr/sbin/redis-server" - <<- EOF
- daemonize yes
- pidfile "${T}"/redis.pid
- unixsocket ${sock}
- EOF
-
- PYTHONPATH="${S}:${S}/tests-hidden"
- esetup.py test
- kill "$(<"${T}/redis.pid")"
-}
diff --git a/dev-python/redis-py/redis-py-2.10.3.ebuild b/dev-python/redis-py/redis-py-2.10.3.ebuild
index b94bf89e9aa0..0ca1dc75e3dc 100644
--- a/dev-python/redis-py/redis-py-2.10.3.ebuild
+++ b/dev-python/redis-py/redis-py-2.10.3.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
inherit distutils-r1
@@ -47,14 +47,7 @@ python_compile() {
fi
}
-src_test() {
- # testsuite fails miserably under multiprocessing
- local DISTUTILS_NO_PARALLEL_BUILD=1
- distutils-r1_src_test
-}
-
python_test() {
-
local sock="${T}/redis.sock"
"${EPREFIX}/usr/sbin/redis-server" - <<- EOF