summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-30 13:40:12 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-30 14:09:25 +0100
commit2a530fa9754864b69c309a16ac2a2df8466f998c (patch)
treeff6890bb317bb35312d1e00bbf5320c32d7e62b2 /dev-python/quantities
parentapp-doc/mathjax-docs: Remove the doc symlink as it violates QA (diff)
downloadgentoo-2a530fa9754864b69c309a16ac2a2df8466f998c.tar.gz
gentoo-2a530fa9754864b69c309a16ac2a2df8466f998c.tar.bz2
gentoo-2a530fa9754864b69c309a16ac2a2df8466f998c.zip
dev-python/quantities: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/quantities')
-rw-r--r--dev-python/quantities/quantities-0.13.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/quantities/quantities-0.13.0-r1.ebuild b/dev-python/quantities/quantities-0.13.0-r1.ebuild
new file mode 100644
index 000000000000..d0c84615b029
--- /dev/null
+++ b/dev-python/quantities/quantities-0.13.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P="python-quantities-${PV}"
+DESCRIPTION="Support for physical quantities with units, based on numpy"
+HOMEPAGE="https://github.com/python-quantities/python-quantities"
+SRC_URI="
+ https://github.com/python-quantities/python-quantities/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.16[$PYTHON_USEDEP]
+"
+
+distutils_enable_tests pytest