summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-19 00:08:27 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-19 00:35:19 +0100
commit97212d31c2200a6a1d89384a7d96f81242a96a07 (patch)
treeeed6f4cb9f295ef6de8778fb1b8e6c90b8d56a45 /dev-python/python-magic/python-magic-0.4.22.ebuild
parentnet-dialup/freeradius-client: Stabilize 1.1.7-r1 arm, #771255 (diff)
downloadgentoo-97212d31c2200a6a1d89384a7d96f81242a96a07.tar.gz
gentoo-97212d31c2200a6a1d89384a7d96f81242a96a07.tar.bz2
gentoo-97212d31c2200a6a1d89384a7d96f81242a96a07.zip
dev-python/python-magic: Bump to 0.4.22
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-magic/python-magic-0.4.22.ebuild')
-rw-r--r--dev-python/python-magic/python-magic-0.4.22.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/python-magic/python-magic-0.4.22.ebuild b/dev-python/python-magic/python-magic-0.4.22.ebuild
new file mode 100644
index 000000000000..a4807619f588
--- /dev/null
+++ b/dev-python/python-magic/python-magic-0.4.22.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Access the libmagic file type identification library"
+HOMEPAGE="https://github.com/ahupp/python-magic"
+SRC_URI="
+ https://github.com/ahupp/python-magic/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-apps/file[-python]"
+BDEPEND="
+ test? ( sys-apps/file )
+"
+
+python_test() {
+ local -x LC_ALL=en_US.UTF-8
+ "${EPYTHON}" test/test.py -v || die "Tests fail with ${EPYTHON}"
+}