summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2021-05-21 11:45:14 +0300
committerMichał Górny <mgorny@gentoo.org>2021-05-22 12:52:12 +0200
commit1a8b813c5042bb1d903cd0ca3ca58c12ca521b0e (patch)
tree42bc40025d032c0bbfd17ccd726d52c0050f053c /dev-python/python-jose
parentdev-ada/gnatcoll-core: enable gnat_2020, fix VariableScope (diff)
downloadgentoo-1a8b813c5042bb1d903cd0ca3ca58c12ca521b0e.tar.gz
gentoo-1a8b813c5042bb1d903cd0ca3ca58c12ca521b0e.tar.bz2
gentoo-1a8b813c5042bb1d903cd0ca3ca58c12ca521b0e.zip
dev-python/python-jose: bump to python 3.10
passes tests Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-jose')
-rw-r--r--dev-python/python-jose/python-jose-3.2.0-r1.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/dev-python/python-jose/python-jose-3.2.0-r1.ebuild b/dev-python/python-jose/python-jose-3.2.0-r1.ebuild
index 84bbcfea7cd6..6b5270e414ea 100644
--- a/dev-python/python-jose/python-jose-3.2.0-r1.ebuild
+++ b/dev-python/python-jose/python-jose-3.2.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
+
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
DESCRIPTION="A JavaScript Object Signing and Encryption (JOSE) implementation in Python"
@@ -31,7 +31,12 @@ python_prepare_all() {
-e '/ecdsa/s:<0.15::' \
-i setup.py || die
sed -e '/addopts/d' -i setup.cfg || die
- sed -e 's:test_key_too_short:_&:' \
- -i tests/algorithms/test_EC.py || die
distutils-r1_python_prepare_all
}
+
+python_test() {
+ local deselect=(
+ tests/algorithms/test_EC.py::TestECAlgorithm::test_key_too_short
+ )
+ epytest ${deselect[@]/#/--deselect }
+}