summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-10-25 14:40:05 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-10-25 14:56:18 +0200
commitc5e51749c6444ad85d6bfa999c18c95356308949 (patch)
treeaf95c85f7027a6d0460306909affc98aeb69278f /dev-python/pytest-tornado
parentdev-python/ipykernel: add version 6.4.2, re-enable python3.10 (diff)
downloadgentoo-c5e51749c6444ad85d6bfa999c18c95356308949.tar.gz
gentoo-c5e51749c6444ad85d6bfa999c18c95356308949.tar.bz2
gentoo-c5e51749c6444ad85d6bfa999c18c95356308949.zip
dev-python/pytest-tornado: import from ::guru
new test dep of ipyparallel Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/pytest-tornado')
-rw-r--r--dev-python/pytest-tornado/Manifest1
-rw-r--r--dev-python/pytest-tornado/metadata.xml17
-rw-r--r--dev-python/pytest-tornado/pytest-tornado-0.8.1.ebuild24
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pytest-tornado/Manifest b/dev-python/pytest-tornado/Manifest
new file mode 100644
index 000000000000..cbdd05280393
--- /dev/null
+++ b/dev-python/pytest-tornado/Manifest
@@ -0,0 +1 @@
+DIST pytest-tornado-0.8.1.tar.gz 12616 BLAKE2B 0e9668056c5f6dafd242f311825f830fe1e6428f4c38d030bb0a119f8ae54d511debdb4f839adcfa0881d6ecc79e4889dbed80121cd7a3d4bfb75dd901cb234e SHA512 e655ee9e28461c68b6cc642dbbb203a31154305a603951641e795c605f55970243bb9f7a8858a44bf70faba3d647bea6cf1525f2f9655a968cabbea43beec3d6
diff --git a/dev-python/pytest-tornado/metadata.xml b/dev-python/pytest-tornado/metadata.xml
new file mode 100644
index 000000000000..48f39885b0d3
--- /dev/null
+++ b/dev-python/pytest-tornado/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pytest-tornado</remote-id>
+ <remote-id type="github">eugeniy/pytest-tornado</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-tornado/pytest-tornado-0.8.1.ebuild b/dev-python/pytest-tornado/pytest-tornado-0.8.1.ebuild
new file mode 100644
index 000000000000..9d8fa9c89b2f
--- /dev/null
+++ b/dev-python/pytest-tornado/pytest-tornado-0.8.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fixtures and markers to simplify testing of asynchronous tornado applications"
+HOMEPAGE="https://github.com/eugeniy/pytest-tornado"
+SRC_URI="https://github.com/eugeniy/pytest-tornado/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
+ >=www-servers/tornado-5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests --install pytest