summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-12 18:44:27 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-12 18:54:42 +0200
commit5603db22a8b77232621e6a7a880c3093b1e5a929 (patch)
treeaf8002984c1a7e19fa773ba2952543c23c06e281 /dev-python/pytest-timeout
parentdev-python/pytest-shutil: Remove redundant versions (diff)
downloadgentoo-5603db22a8b77232621e6a7a880c3093b1e5a929.tar.gz
gentoo-5603db22a8b77232621e6a7a880c3093b1e5a929.tar.bz2
gentoo-5603db22a8b77232621e6a7a880c3093b1e5a929.zip
dev-python/pytest-timeout: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-timeout')
-rw-r--r--dev-python/pytest-timeout/Manifest2
-rw-r--r--dev-python/pytest-timeout/files/pytest-timeout-1.3.3-tests.patch25
-rw-r--r--dev-python/pytest-timeout/pytest-timeout-1.3.3.ebuild30
-rw-r--r--dev-python/pytest-timeout/pytest-timeout-1.4.0.ebuild32
4 files changed, 0 insertions, 89 deletions
diff --git a/dev-python/pytest-timeout/Manifest b/dev-python/pytest-timeout/Manifest
index e451e46a1525..fa27ed99f7b5 100644
--- a/dev-python/pytest-timeout/Manifest
+++ b/dev-python/pytest-timeout/Manifest
@@ -1,4 +1,2 @@
-DIST pytest-timeout-1.3.3.tar.gz 11627 BLAKE2B e20348cc461ad03e95c22a16e753b72441ee70da9769214f4d07db15818a8997339ced47244b15de62a61107eb749dff8d6f41ddb4720c925ef1e6eb9962db27 SHA512 633f5aee550d568e403b958f4490ecb828eb322811c9f18cfefb26613be4fc36da14232ecbef8666fcf2dc693a93674c00a853ab546ea8328a07ea34da79fb84
DIST pytest-timeout-1.3.4.tar.gz 12255 BLAKE2B c8991e0255a490048f43e1163d0315cb8fabfaf9d96deb476e2d59da7efce8c63da09b1e8e6f9d6f3fe82b3c6f67608b5e5db117e6378a041ca6e5ba9c71fc05 SHA512 29af25f3c3776d9ef63c6b7217ffc6b0cedd873b8cc96be742a642da84d12c8988bb9b409e00850246e554b21908d6fd2207692650b154cf6831f38c4395bc80
-DIST pytest-timeout-1.4.0.tar.gz 13661 BLAKE2B d55cf85e44da1e8216d28d08c6783e720a37dbc4bed58c82a24918ac471e8d66f33967f16a249aa5307d0e227082e5628c06041b1bbd12e251a97449c69e5cb5 SHA512 457e30c0746e2762f4a62b0cdbad4f7ca4514175d97daa97fdbb1ebab8743085e828336f137a9cc7dc655c0827c038177195b589ed531d81bb911b6e5e5c875d
DIST pytest-timeout-1.4.1.tar.gz 13804 BLAKE2B 45e9bdf6eb39e706cac2c9484cd34a9f16096d71d0146251bef9591c35c269043c95e641bed40b25e3d2076fe29a5782363bf9130b331eb04c4e867b1e8f646b SHA512 b62b090365c1cfe1a4d544b5645f828e451ec5229313c50a26ce04ba6cb203ff9ab487c61fb000af342f3d499e11f67aff5f84ff5b00328a129f1f39d4aabf28
diff --git a/dev-python/pytest-timeout/files/pytest-timeout-1.3.3-tests.patch b/dev-python/pytest-timeout/files/pytest-timeout-1.3.3-tests.patch
deleted file mode 100644
index d3fa9ca0fd34..000000000000
--- a/dev-python/pytest-timeout/files/pytest-timeout-1.3.3-tests.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -ur pytest-timeout-1.3.3.orig/test_pytest_timeout.py pytest-timeout-1.3.3/test_pytest_timeout.py
---- pytest-timeout-1.3.3.orig/test_pytest_timeout.py 2018-11-16 03:41:33.000000000 -0800
-+++ pytest-timeout-1.3.3/test_pytest_timeout.py 2019-11-21 22:34:08.429287370 -0800
-@@ -1,4 +1,5 @@
- import os
-+import platform
- import os.path
- import signal
- import time
-@@ -93,6 +94,6 @@
- # assert 'Timeout' in result.stdout.str() + result.stderr.str()
-
-
--@pytest.mark.parametrize('meth', [have_sigalrm('signal'), 'thread'])
-+@pytest.mark.parametrize('meth', [pytest.param('signal', marks=have_sigalrm), 'thread'])
- @pytest.mark.parametrize('scope', ['function', 'class', 'module', 'session'])
- def test_fix_setup(meth, scope, testdir):
-@@ -133,6 +134,6 @@
- assert 'Timeout' not in result.stdout.str() + result.stderr.str()
-
-
--@pytest.mark.parametrize('meth', [have_sigalrm('signal'), 'thread'])
-+@pytest.mark.parametrize('meth', [pytest.param('signal', marks=have_sigalrm), 'thread'])
- @pytest.mark.parametrize('scope', ['function', 'class', 'module', 'session'])
- def test_fix_finalizer(meth, scope, testdir):
diff --git a/dev-python/pytest-timeout/pytest-timeout-1.3.3.ebuild b/dev-python/pytest-timeout/pytest-timeout-1.3.3.ebuild
deleted file mode 100644
index 2b7786b403a9..000000000000
--- a/dev-python/pytest-timeout/pytest-timeout-1.3.3.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="py.test plugin to abort hanging tests"
-HOMEPAGE="https://pypi.org/project/pytest-timeout/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-PATCHES=(
- "${FILESDIR}/pytest-timeout-1.3.3-tests.patch"
-)
-
-python_test() {
- distutils_install_for_testing
-
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/pytest-timeout/pytest-timeout-1.4.0.ebuild b/dev-python/pytest-timeout/pytest-timeout-1.4.0.ebuild
deleted file mode 100644
index 7b3e50afe479..000000000000
--- a/dev-python/pytest-timeout/pytest-timeout-1.4.0.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="py.test plugin to abort hanging tests"
-HOMEPAGE="https://pypi.org/project/pytest-timeout/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- ${RDEPEND}
- dev-python/pexpect[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- distutils_install_for_testing
-
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}