summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-16 06:44:52 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-16 07:04:56 +0200
commit5b51928ae2b942190d7df0887328e0a5175cbfa9 (patch)
tree9956b2845b48130cefa114acb63a8c234d17a456 /dev-python/pytest-subtests
parentdev-python/sentry-sdk: Bump to 1.23.0 (diff)
downloadgentoo-5b51928ae2b942190d7df0887328e0a5175cbfa9.tar.gz
gentoo-5b51928ae2b942190d7df0887328e0a5175cbfa9.tar.bz2
gentoo-5b51928ae2b942190d7df0887328e0a5175cbfa9.zip
dev-python/pytest-subtests: Bump to 0.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-subtests')
-rw-r--r--dev-python/pytest-subtests/Manifest1
-rw-r--r--dev-python/pytest-subtests/pytest-subtests-0.11.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pytest-subtests/Manifest b/dev-python/pytest-subtests/Manifest
index 04b35ff49606..9d1f9c475b11 100644
--- a/dev-python/pytest-subtests/Manifest
+++ b/dev-python/pytest-subtests/Manifest
@@ -1 +1,2 @@
DIST pytest-subtests-0.10.0.gh.tar.gz 10253 BLAKE2B dba434dfc3f27293d5576ad408665917394ff54d41aef5604f40d787c4d7d9c6fc42b99ca10a8d46707fc8ce0eb5aab8e27bb32b464f5c9350f6bda6b12df031 SHA512 2fc3f8316db879d64d4dd4ad53df7dbda30b69df9291608eb6235aa27e9e6b3ec4174023f9ffa016811eb8955f0ebd673ead7b7319d927d18d7c016e0c7ef573
+DIST pytest-subtests-0.11.0.tar.gz 12763 BLAKE2B b1e1373d197798a9c27ed65569a681e9ea8dd36014cf6ea57a1d44ed888dca21bd8c5afffeb7f590a501d83d1bc0a8e1fe06b13832173e6937b722163614f21e SHA512 cab486252148e457e234e0dadacefa5ff38cf67df48d9c8bd61aa546a4a1e712b70dca0a270dffceede6be0f8a6324e8c21beaa4d1528b39f12bba72e077ef1d
diff --git a/dev-python/pytest-subtests/pytest-subtests-0.11.0.ebuild b/dev-python/pytest-subtests/pytest-subtests-0.11.0.ebuild
new file mode 100644
index 000000000000..b10cb02ed428
--- /dev/null
+++ b/dev-python/pytest-subtests/pytest-subtests-0.11.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Unittest subTest() support and subtests fixture"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-subtests/
+ https://pypi.org/project/pytest-subtests/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7[${PYTHON_USEDEP}]
+"
+# pytest-xdist is used to test compatibility
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked,pytest_subtests
+ epytest
+}