summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-22 09:41:33 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-22 10:49:58 +0200
commitbbdf08f4d71a71c587b3bf757fd717febe47abbb (patch)
tree8c1340fad19196b2a151e3a8ab137165d1398cd1 /dev-python/pytest-recording
parentapp-emacs/treemacs: remove unused patch (diff)
downloadgentoo-bbdf08f4d71a71c587b3bf757fd717febe47abbb.tar.gz
gentoo-bbdf08f4d71a71c587b3bf757fd717febe47abbb.tar.bz2
gentoo-bbdf08f4d71a71c587b3bf757fd717febe47abbb.zip
dev-python/pytest-recording: New package, v0.13.0
New test dep for dev-python/moddb. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-recording')
-rw-r--r--dev-python/pytest-recording/Manifest1
-rw-r--r--dev-python/pytest-recording/metadata.xml12
-rw-r--r--dev-python/pytest-recording/pytest-recording-0.13.0.ebuild46
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pytest-recording/Manifest b/dev-python/pytest-recording/Manifest
new file mode 100644
index 000000000000..18cd14ac4930
--- /dev/null
+++ b/dev-python/pytest-recording/Manifest
@@ -0,0 +1 @@
+DIST pytest_recording-0.13.0.tar.gz 25027 BLAKE2B c325aaf809617886e85c3fa597c36858c7e1a9cb1552a18c8ee27f5a7479b66469b61bce51ceb14fc9dd5fa420c20803ed016875eef1a0cf05de5293ead24bfc SHA512 2e9ab39971d89f838f2d778d1d80fdb5519b39855a69019eeeb22d69ca3c92ecb14a7eda7b55ec37ea07fae0c3316c9c16932a0afcf0abe0dbfefc31fe23bd68
diff --git a/dev-python/pytest-recording/metadata.xml b/dev-python/pytest-recording/metadata.xml
new file mode 100644
index 000000000000..9fa86cdaa74d
--- /dev/null
+++ b/dev-python/pytest-recording/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">kiwicom/pytest-recording</remote-id>
+ <remote-id type="pypi">pytest-recording</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-recording/pytest-recording-0.13.0.ebuild b/dev-python/pytest-recording/pytest-recording-0.13.0.ebuild
new file mode 100644
index 000000000000..cc8d63257553
--- /dev/null
+++ b/dev-python/pytest-recording/pytest-recording-0.13.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pytest plugin to record network interactions via VCR.py"
+HOMEPAGE="
+ https://pypi.org/project/pytest-recording/
+ https://github.com/kiwicom/pytest-recording/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pytest-3.5.0[${PYTHON_USEDEP}]
+ >=dev-python/vcrpy-2.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test () {
+ local EPYTEST_DESELECT=(
+ # Internet
+ # https://github.com/kiwicom/pytest-recording/issues/131
+ tests/test_blocking_network.py::test_block_network_with_allowed_hosts
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_recording.plugin
+ PYTEST_PLUGINS+=,pytest_httpbin.plugin,pytest_mock
+ epytest
+}