summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-19 23:45:01 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-19 23:53:26 +0200
commit5cffd73ad45761e45f9b3c958532b9042e6731e4 (patch)
tree514136ac7721db79a422b2476821652647b594b4 /dev-python/pytest-httpx
parentdev-python/httpx: Bump to 0.19.0 (diff)
downloadgentoo-5cffd73ad45761e45f9b3c958532b9042e6731e4.tar.gz
gentoo-5cffd73ad45761e45f9b3c958532b9042e6731e4.tar.bz2
gentoo-5cffd73ad45761e45f9b3c958532b9042e6731e4.zip
dev-python/pytest-httpx: Bump to 0.13.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-httpx')
-rw-r--r--dev-python/pytest-httpx/Manifest1
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.13.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index bf6dc4cb4fd4..34c0621a19e1 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1,2 +1,3 @@
DIST pytest-httpx-0.12.0.tar.gz 21319 BLAKE2B 59c3678937a7756f13971e3f1f8d312b227f56339b4234ac8e5544f4370622bcff401f76f68c2ee042fdc64deae6a7a9dd05ca8a54b60b14bfb74b2d2d724de4 SHA512 b5866ab0123755020fad679d27d4d113132b2a79da85c52a334904d19aea90ddc71088a6e0f27110498da2731be664c525f3cab256d447a37d9a507f9a508b43
DIST pytest-httpx-0.12.1.tar.gz 21422 BLAKE2B 6336a79d3aedbba7ec32fdafc6ed6fd70a24354adcdd3803af73522f9eb2d5bb1ac51364c107d3ca663f2c627a29fa9d3b0c12ba1bcba94259932a36c7695ed4 SHA512 959906c366b3cfc4d3df46773888f1da0c65ca4a9d31de302c859a61a71f10df5712b058bf89132756028eda15c35241aa245bc708d69560a0d3a80f9fa1e814
+DIST pytest-httpx-0.13.0.tar.gz 21515 BLAKE2B 691ce45dd2b27c8f47724e3356ba96e62a0d6a7ce7d3feea68295a873c12f9a3df00d5b25aad7ef8a1154e887077ae6f6c1b12f3685a0669534a0d0ee8aae68c SHA512 514d9acacdfd60d13b5ce2c5ebe46d0e4d16c1b06fd359b0b9515ae2fa9091296537f369882a78bdfad48e9a0aad0b2f8c172c2e54f4ae9e23ba03220c7c17fb
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.13.0.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.13.0.ebuild
new file mode 100644
index 000000000000..684f00600e08
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.13.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="https://colin-b.github.io/pytest_httpx/"
+SRC_URI="https://github.com/Colin-b/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.19*[${PYTHON_USEDEP}]
+ =dev-python/pytest-6*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest