summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-22 06:12:29 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-22 06:38:51 +0100
commit11415481988d36378291c28c028284b5b2444d22 (patch)
treec89688a147b52e1cdbcfbdd87e7f8eba23e5aa98 /dev-python/pytest-httpx
parentdev-python/httpx: Bump to 0.27.0 (diff)
downloadgentoo-11415481988d36378291c28c028284b5b2444d22.tar.gz
gentoo-11415481988d36378291c28c028284b5b2444d22.tar.bz2
gentoo-11415481988d36378291c28c028284b5b2444d22.zip
dev-python/pytest-httpx: Bump to 0.30.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-httpx')
-rw-r--r--dev-python/pytest-httpx/Manifest1
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.30.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index 0c4447db80e5..1e87ce872f33 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1 +1,2 @@
+DIST pytest-httpx-0.30.0.tar.gz 36959 BLAKE2B b56f0e51558ffa6eb0c0af61aa3633a8e358f8c78916d101f1de853f683136a68e195bf0af099bbc6766198b4136a560ffd2676d9a49f0b350882896a61d935a SHA512 6aadb544bda5003156bf9c0fa309a166636dc87aea033d9a48ee10e1e8b77e6cb52350930e97cab89cff7c10111d5e26d1d74cd33f0a6c54e34c3fb7ef72ea05
DIST pytest_httpx-0.29.0.tar.gz 34103 BLAKE2B b8ee299ce17861732050f0059905193ee964ca375734584356b26a179979f2f967b69d134b8fc9c0fd4ae75172c404dc8e9ec27bb50e6bed58f8e7e76a4aa9e6 SHA512 ada6f5f419de3fbe835a5ce9fba9e5d368cbb01d1826d61cd4bb5a7f2941030d40afa17e582eca20743a546bf98699ecc2d8a0c640efa69b390dc32f2349bb13
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.30.0.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.30.0.ebuild
new file mode 100644
index 000000000000..20f3b769ac44
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.30.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.27*[${PYTHON_USEDEP}]
+ <dev-python/pytest-9[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest