summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-20 21:56:18 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-20 22:38:15 +0100
commit0cf0f2b919638440c682ba028c52a55f385c04d3 (patch)
treedf792c58705787931845a91e889fd9ab9be83946 /dev-python/pytest-httpx
parentdev-python/hypothesis: Bump to 6.63.0 (diff)
downloadgentoo-0cf0f2b919638440c682ba028c52a55f385c04d3.tar.gz
gentoo-0cf0f2b919638440c682ba028c52a55f385c04d3.tar.bz2
gentoo-0cf0f2b919638440c682ba028c52a55f385c04d3.zip
dev-python/pytest-httpx: Bump to 0.21.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-httpx')
-rw-r--r--dev-python/pytest-httpx/Manifest1
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.21.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index 2e6d0134e908..e4143bd4e0b4 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1 +1,2 @@
DIST pytest-httpx-0.21.2.gh.tar.gz 24311 BLAKE2B ae1ce7ada3977c3bd68f31b5e20e93ac32f2459359bcff30d1ccf358b07ce269f38acb06b46211ddaed1085a9cf78fcefb921a978a5ca4f6c84fe25b602a3a25 SHA512 d8a9d1381a7c1bb1f907effce48bcd4cad29b2eb135e5d18e7ba3025ba2f18d97c7914f0cfb835416dfa608c59ed51db653b0366d407cfbb82fc520808f3792e
+DIST pytest-httpx-0.21.3.gh.tar.gz 24373 BLAKE2B 8efa85974128a0c9d78bbc23b7c9bca17e68ebb09dafd3b49e5a09df54bd2808ab6e7995ab407b78495ac12a80239d7397169c8de539ec559a8c7cf95239b495 SHA512 8c25a702b9c049354a0f0b232eefeae5ac0c47764af023c89aba6829309971a1d79a0dab3e4d6275a6bf0f32f3a8309c9559eb22c9b742a6576ecea37ff0d15d
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.21.3.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.21.3.ebuild
new file mode 100644
index 000000000000..fe25b787d728
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.21.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+SRC_URI="
+ https://github.com/Colin-b/pytest_httpx/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.23*[${PYTHON_USEDEP}]
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest