summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-21 12:39:21 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-21 12:43:11 +0200
commit0fa7ac0210895b8754d042c410a88014b734059c (patch)
treeafddc3d4701b2daaa4f9c64d3eb360f4b38c7037 /dev-python/pytest-django
parentdev-python/llfuse: Stabilize 1.5.1 amd64, #939992 (diff)
downloadgentoo-0fa7ac0210895b8754d042c410a88014b734059c.tar.gz
gentoo-0fa7ac0210895b8754d042c410a88014b734059c.tar.bz2
gentoo-0fa7ac0210895b8754d042c410a88014b734059c.zip
dev-python/pytest-django: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-django')
-rw-r--r--dev-python/pytest-django/Manifest1
-rw-r--r--dev-python/pytest-django/pytest-django-4.8.0.ebuild51
2 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/pytest-django/Manifest b/dev-python/pytest-django/Manifest
index 7a3c405f645a..99afb67d665f 100644
--- a/dev-python/pytest-django/Manifest
+++ b/dev-python/pytest-django/Manifest
@@ -1,2 +1 @@
-DIST pytest-django-4.8.0.gh.tar.gz 77646 BLAKE2B 206357110066d233c103755cfd6324e8042d9c93442c25db17a13f02132eab60a315856441e26d43a3c493cf72ce39ef51163ccc5368941875e63656bf9122a7 SHA512 8f7ba6b28cc4c0347876beb85247ccd021767811b9122c8cd0fb5d051df4ae76267b27a3fee5c36882a40716bdcbaab43abf71ef8dd61757087b12fd141632aa
DIST pytest-django-4.9.0.gh.tar.gz 78407 BLAKE2B 0ab7dd12494fdb5c66ceabc67c793f7d970258a1a1b7cd3f7b31b6ee5087436396936a0a1672d77ab3c7e391f00bc63060e137ee9399a52940ebbc2ba25e253e SHA512 ec4cb8e9220cd21d96b72c1f09cfdd023700831ed583fe79d84a85f8d24eeaf3f111580d672950feecad69455078f0c73879f0d73364e74a4577352a4d8a1d4d
diff --git a/dev-python/pytest-django/pytest-django-4.8.0.ebuild b/dev-python/pytest-django/pytest-django-4.8.0.ebuild
deleted file mode 100644
index 8ecffef4a793..000000000000
--- a/dev-python/pytest-django/pytest-django-4.8.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1
-
-DESCRIPTION="A Django plugin for pytest"
-HOMEPAGE="
- https://pypi.org/project/pytest-django/
- https://pytest-django.readthedocs.io/
- https://github.com/pytest-dev/pytest-django/
-"
-SRC_URI="
- https://github.com/pytest-dev/pytest-django/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~loong ppc ppc64 ~riscv ~sparc x86"
-
-RDEPEND="
- >=dev-python/pytest-7.0.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/setuptools-scm-1.11.1[${PYTHON_USEDEP}]
- test? (
- dev-python/django[${PYTHON_USEDEP}]
- >=dev-python/django-configurations-2.0[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x DJANGO_SETTINGS_MODULE
- local -x PYTHONPATH=${PWD}
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_django.plugin,xdist.plugin
- for DJANGO_SETTINGS_MODULE in pytest_django_test.settings_sqlite{,_file}; do
- einfo "Testing ${DJANGO_SETTINGS_MODULE}"
- epytest tests
- done
-}