summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-04-19 13:36:56 -0700
committerPatrick McLean <chutzpah@gentoo.org>2023-04-20 09:57:55 -0700
commit2d9890087939cdb0b640feb228805c0593575659 (patch)
treee2889a004eb8e3261bc799354389055576ebadce /dev-python/pytest-custom-exit-code
parentdev-python/pytest-salt-factories: add 1.0.0_rc23 (diff)
downloadgentoo-2d9890087939cdb0b640feb228805c0593575659.tar.gz
gentoo-2d9890087939cdb0b640feb228805c0593575659.tar.bz2
gentoo-2d9890087939cdb0b640feb228805c0593575659.zip
dev-python/pytest-custom-exit-code: new package, add 0.3.0
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pytest-custom-exit-code')
-rw-r--r--dev-python/pytest-custom-exit-code/Manifest1
-rw-r--r--dev-python/pytest-custom-exit-code/metadata.xml12
-rw-r--r--dev-python/pytest-custom-exit-code/pytest-custom-exit-code-0.3.0.ebuild39
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pytest-custom-exit-code/Manifest b/dev-python/pytest-custom-exit-code/Manifest
new file mode 100644
index 000000000000..21949871acfd
--- /dev/null
+++ b/dev-python/pytest-custom-exit-code/Manifest
@@ -0,0 +1 @@
+DIST pytest-custom-exit-code-0.3.0.gh.tar.gz 11147 BLAKE2B 1ffbd021f9b637de19bccc7f6fe41048b6fc600236a29faa2e9729c814ce42c8d08ec19f29de4852ec3f82f6ec850740f5bb2c7119e047c2498edbed2c8bb6dd SHA512 6b412866d60580908d6e53829ca7c5661a7a7ff4927f014e8765315da6152c1e459b5076874a11c54f7b90e7a0480011d80d883d51f437a1780ad8442366e3a5
diff --git a/dev-python/pytest-custom-exit-code/metadata.xml b/dev-python/pytest-custom-exit-code/metadata.xml
new file mode 100644
index 000000000000..7205210a2a24
--- /dev/null
+++ b/dev-python/pytest-custom-exit-code/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-custom-exit-code</remote-id>
+ <remote-id type="github">yashtodi94/pytest-custom_exit_code</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-custom-exit-code/pytest-custom-exit-code-0.3.0.ebuild b/dev-python/pytest-custom-exit-code/pytest-custom-exit-code-0.3.0.ebuild
new file mode 100644
index 000000000000..9e5a9c834bf5
--- /dev/null
+++ b/dev-python/pytest-custom-exit-code/pytest-custom-exit-code-0.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+inherit distutils-r1
+
+MY_PN=${PN//-/_}
+MY_PN=${MY_PN/_/-}
+
+DESCRIPTION="Exit pytest test session with custom exit code in different scenarios"
+HOMEPAGE="
+ https://pypi.org/project/pytest-custom-exit-code/
+ https://github.com/yashtodi94/pytest-custom_exit_code
+"
+
+SRC_URI="https://github.com/yashtodi94/${MY_PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pytest-7.0.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests
+}