summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-19 10:44:47 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-19 10:44:47 +0200
commitd62a95796704aa459aadabc1b714a346ca1f5be3 (patch)
tree71b9bb7d330b4ade8cc0b4b3825141558a741cd6 /dev-python/pytest-cov
parentdev-python/pastedeploy: drop 2.1.1-r3 (diff)
downloadgentoo-d62a95796704aa459aadabc1b714a346ca1f5be3.tar.gz
gentoo-d62a95796704aa459aadabc1b714a346ca1f5be3.tar.bz2
gentoo-d62a95796704aa459aadabc1b714a346ca1f5be3.zip
dev-python/pytest-cov: drop 3.0.0-r2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-cov')
-rw-r--r--dev-python/pytest-cov/Manifest1
-rw-r--r--dev-python/pytest-cov/pytest-cov-3.0.0-r2.ebuild59
2 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/pytest-cov/Manifest b/dev-python/pytest-cov/Manifest
index c4e0c945f72b..69d38d493d4b 100644
--- a/dev-python/pytest-cov/Manifest
+++ b/dev-python/pytest-cov/Manifest
@@ -1,2 +1 @@
-DIST pytest-cov-3.0.0.tar.gz 61440 BLAKE2B 85f0b079c4c373191553271e34e78af68ac69ea53e3721aa0d43eb9dd55be935570eb15c0f8b954e4c0de6201c004ddef435ea70b03cfda893ecdcc230c283e7 SHA512 289d1b1e29dcc3461276de4c1bbd3884e4ec957efb7dd4c330bc3f25f1b978cbee64c0e2882b419eee5f9ccf44c9d1a23ce47a1b7cc7e436b9ebe894e4c11ae8
DIST pytest-cov-4.0.0.tar.gz 62013 BLAKE2B af8a12955e3f22cd9dc257874f86c04c3c6e29f4af2d2838f37ca196c4955dcf4007c7b404f31c303d0eef6c3735fa1a6268c3bb9f01ed54860750ca2f83b6f5 SHA512 fb993be4d86b29a44e4f2ccd2309d99ab9fe8e6b291abbc2a8a3fc8b36479491165a242a20bfa9886dfd296fcc827da9984b556fdbe9a3ac496ac5b6ba379012
diff --git a/dev-python/pytest-cov/pytest-cov-3.0.0-r2.ebuild b/dev-python/pytest-cov/pytest-cov-3.0.0-r2.ebuild
deleted file mode 100644
index 65c69c8579d3..000000000000
--- a/dev-python/pytest-cov/pytest-cov-3.0.0-r2.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="py.test plugin for coverage reporting"
-HOMEPAGE="https://github.com/pytest-dev/pytest-cov https://pypi.org/project/pytest-cov/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
- >=dev-python/coverage-6.4.4-r1[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-python/fields[${PYTHON_USEDEP}]
- >=dev-python/process-tests-2.0.2[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs \
- dev-python/sphinx-py3doc-enhanced-theme
-distutils_enable_tests pytest
-
-PATCHES=(
- # https://github.com/pytest-dev/pytest-cov/pull/518
- "${FILESDIR}"/${P}-coverage-6.2.patch
-)
-
-python_test() {
- # NB: disabling all plugins speeds tests up a lot
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_cov.plugin,xdist.plugin,xdist.looponfail
-
- local EPYTEST_DESELECT=(
- # attempts to install packages via pip (network)
- tests/test_pytest_cov.py::test_dist_missing_data
- )
-
- # TODO: why do we need to do that?!
- # https://github.com/pytest-dev/pytest-cov/issues/517
- ln -s "${BROOT}$(python_get_sitedir)/coverage" \
- "${BUILD_DIR}/install$(python_get_sitedir)/coverage" || die
-
- epytest -x
-
- rm "${BUILD_DIR}/install$(python_get_sitedir)/coverage" || die
-}