summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-27 17:46:21 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-27 17:59:47 +0200
commita8111e29d2ace9c37bcb69a0936a0c5a92de8a7c (patch)
tree45d4fe8e63853668ee7bed01a1f5142af4f2a564 /dev-python/pystache
parentdev-python/starlette: Bump to 0.31.1 (diff)
downloadgentoo-a8111e29d2ace9c37bcb69a0936a0c5a92de8a7c.tar.gz
gentoo-a8111e29d2ace9c37bcb69a0936a0c5a92de8a7c.tar.bz2
gentoo-a8111e29d2ace9c37bcb69a0936a0c5a92de8a7c.zip
dev-python/pystache: Bump to 0.6.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pystache')
-rw-r--r--dev-python/pystache/Manifest1
-rw-r--r--dev-python/pystache/pystache-0.6.5.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pystache/Manifest b/dev-python/pystache/Manifest
index ba2e3a1cb113..09bc0f20a22d 100644
--- a/dev-python/pystache/Manifest
+++ b/dev-python/pystache/Manifest
@@ -1 +1,2 @@
DIST pystache-0.6.1.gh.tar.gz 279050 BLAKE2B 2c61ba260764aa4bf62039bfe1f844d34e26adc29af2f1e1d98619892bfabd3151aa1d34c69596389a68f0d84ce994ddf7114c091d42b497a17b300a5aff36cc SHA512 516d286f84d2c77650550365f6b219acb712376f0b7302fff2aba7dee4d64e3d3fc2d781782777dd37093f6debf52f9d2a40b6ed8b65aa5f7025ff762cb5efae
+DIST pystache-0.6.5.gh.tar.gz 272484 BLAKE2B 8b82aa8922480019e4833333f83d767ef19a1505e2fc708fef0d01c08353b5e600a077c1e86e36c412680381ff6fd310f83857038f383b8218b72269b4e5349b SHA512 e3054e0bff5c3bc6679bf22555dd3cfb2f31b241484c7e6201d37b7767a22f2f842912e3f61d8e2e2858615a4f99ef4192d885b60f84dfeffa1408370ccfba75
diff --git a/dev-python/pystache/pystache-0.6.5.ebuild b/dev-python/pystache/pystache-0.6.5.ebuild
new file mode 100644
index 000000000000..c10cd9359cc2
--- /dev/null
+++ b/dev-python/pystache/pystache-0.6.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Updated Python implementation of Mustache templating framework"
+HOMEPAGE="
+ https://github.com/PennyDreadfulMTG/pystache/
+ https://pypi.org/project/pystache/
+"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/PennyDreadfulMTG/pystache.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/PennyDreadfulMTG/pystache/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+BDEPEND="
+ test? (
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest