summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-08-15 07:42:19 +0200
committerMichał Górny <mgorny@gentoo.org>2015-08-15 07:44:57 +0200
commitf1a1ce103ab659640dd4a20901f2d2e7a72b6336 (patch)
treef187e8fd61cf2718beb557628e57cd85be12a614 /dev-python/pypy3
parentdev-ruby/rails-dom-testing: version bump (diff)
downloadgentoo-f1a1ce103ab659640dd4a20901f2d2e7a72b6336.tar.gz
gentoo-f1a1ce103ab659640dd4a20901f2d2e7a72b6336.tar.bz2
gentoo-f1a1ce103ab659640dd4a20901f2d2e7a72b6336.zip
dev-python/pypy*: Fix USE=-ncurses and USE=-gdbm
Fix USE=-ncurses (and USE=-gdbm in pypy-2.6.0) not to try to regenerate cffi modules for the two. Bug: https://bugs.gentoo.org/show_bug.cgi?id=557540#c3 Package-Manager: portage-2.2.20
Diffstat (limited to 'dev-python/pypy3')
-rw-r--r--dev-python/pypy3/pypy3-2.4.0.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/pypy3/pypy3-2.4.0.ebuild b/dev-python/pypy3/pypy3-2.4.0.ebuild
index 20b01f34f5f5..0c369adb0be0 100644
--- a/dev-python/pypy3/pypy3-2.4.0.ebuild
+++ b/dev-python/pypy3/pypy3-2.4.0.ebuild
@@ -197,11 +197,13 @@ src_install() {
# Generate cffi cache
# Please keep in sync with pypy/tool/release/package.py!
- "${PYTHON}" -c "import _curses" || die "Failed to import _curses (cffi)"
"${PYTHON}" -c "import syslog" || die "Failed to import syslog (cffi)"
if use gdbm; then
"${PYTHON}" -c "import _gdbm" || die "Failed to import gdbm (cffi)"
fi
+ if use ncurses; then
+ "${PYTHON}" -c "import _curses" || die "Failed to import _curses (cffi)"
+ fi
if use sqlite; then
"${PYTHON}" -c "import _sqlite3" || die "Failed to import _sqlite3 (cffi)"
fi