summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-12 15:30:54 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-12 17:46:50 -0500
commit63859b135ab9fd1866d075402b47209898cba2a6 (patch)
tree1e996c2f8928f5384a8fcf58fb0c7cf5c379e0a6 /dev-python/pypowervm
parentdev-python/microversion-parse: 0.2.1 add py37 support (diff)
downloadgentoo-63859b135ab9fd1866d075402b47209898cba2a6.tar.gz
gentoo-63859b135ab9fd1866d075402b47209898cba2a6.tar.bz2
gentoo-63859b135ab9fd1866d075402b47209898cba2a6.zip
dev-python/pypowervm: 1.1.20 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/pypowervm')
-rw-r--r--dev-python/pypowervm/Manifest1
-rw-r--r--dev-python/pypowervm/pypowervm-1.1.20.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pypowervm/Manifest b/dev-python/pypowervm/Manifest
index ccf5a8db85a0..af391276f9a6 100644
--- a/dev-python/pypowervm/Manifest
+++ b/dev-python/pypowervm/Manifest
@@ -1,3 +1,4 @@
DIST pypowervm-1.1.10.tar.gz 887266 BLAKE2B 61767773e870fabe2b2954b0e6d13488e7eee83360e7e575fc4ba330148a84f46445c4107929f2e9a2d5ef891195de6374d9c75fd0ee624c71444c338405c8da SHA512 9879b685e46efd4a15f463112bf800884d0e1bdf43ef0fe790bc65334b2f1eeea1b531a0796e1673f4114ea8727c3f3a57bc467934aa535daf17189d0068e253
DIST pypowervm-1.1.16.tar.gz 895383 BLAKE2B 147912526d3d20b4c94be0a57cd28f611d446d2596c07986bc8d8239640e59cd21fc96b41c6107602ab4471f125750ec2da60d456ecd9d806499ebe84a116149 SHA512 d71fac1f6f9d0de903d0fbec6f9eea691882901b1149bd9c57173cd07615475175faa5d27b7e6c6e9a67c4b2ce23eb300dfd7c0689751d3d0d1bcc6d1b9541f1
+DIST pypowervm-1.1.20.tar.gz 906153 BLAKE2B 868571636f3c21b5d179ba587f7693dcf8e55661324d3ba5578be34813a67a5b2881441c3aa3744a9fc1c6ea34626085d62c5829368c43b329edb98804d9fb9c SHA512 1ceaf00f830caef918c27b342f1bf59a41e88593eb36f6c5f01c7a0ef786a69b15d271c87d161f069e12c1224ebb4f6cdf349e31a551bd26fac5206860ba9019
DIST pypowervm-1.1.6.tar.gz 872456 BLAKE2B 02afd4c25aa5f0b005e621fe190decb2724ff289d6f1330744428bd6616a8b784e79486e4e26b46ee76a3e6346f16100cd788f705f264ca9b29b8522a2c8bc9b SHA512 31211b93f85cda9067e29700794daf9aed5c43478c27eb6dd5a150120282a7d46d4fa4fdf5fa038023153b02aae85f236d681e66646912a464bc3d265c87fefa
diff --git a/dev-python/pypowervm/pypowervm-1.1.20.ebuild b/dev-python/pypowervm/pypowervm-1.1.20.ebuild
new file mode 100644
index 000000000000..4d0e0ea1ea3d
--- /dev/null
+++ b/dev-python/pypowervm/pypowervm-1.1.20.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python binding for the PowerVM REST API"
+HOMEPAGE="https://pypi.org/project/pypowervm/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="${DEPEND}
+ >=dev-python/lxml-3.4.1[${PYTHON_USEDEP}]
+ !~dev-python/lxml-3.7.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-context-2.14.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-i18n-3.15.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.22.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.20.0[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ >=dev-python/taskflow-2.16.0[${PYTHON_USEDEP}]"