summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-21 21:44:45 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-21 21:56:23 +0200
commit7d0b5a15413f92ddf8acf497ba86d03c2ea621e1 (patch)
treeaed0ea2319f5b70d1a62a66edba115c65a5dac3f /dev-python/pyopenssl
parentdev-python/cryptography: Reenable pypy3 (diff)
downloadgentoo-7d0b5a15413f92ddf8acf497ba86d03c2ea621e1.tar.gz
gentoo-7d0b5a15413f92ddf8acf497ba86d03c2ea621e1.tar.bz2
gentoo-7d0b5a15413f92ddf8acf497ba86d03c2ea621e1.zip
dev-python/pyopenssl: Bump to 22.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyopenssl')
-rw-r--r--dev-python/pyopenssl/Manifest1
-rw-r--r--dev-python/pyopenssl/pyopenssl-22.0.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/pyopenssl/Manifest b/dev-python/pyopenssl/Manifest
index cfda79f1614f..d86710437518 100644
--- a/dev-python/pyopenssl/Manifest
+++ b/dev-python/pyopenssl/Manifest
@@ -1 +1,2 @@
DIST pyOpenSSL-20.0.1.tar.gz 173736 BLAKE2B 37e1741425a296142d38c20c70f9950eec2bd043fc58e50c9955b98dc6825111328af852d247b154aa120ab42ea9dc2ae8186d350dd0c664cd5920b9a902963e SHA512 e81e0870398b882d77453b02e972559c0be82dbfe87bd8a48a65e8943acc3ea07dc8c3150b88e299c237496043443d1a5832219c337e4436f99ef419b36dd23f
+DIST pyOpenSSL-22.0.0.tar.gz 178438 BLAKE2B d34c91a54aaf6b28d92ba83c26900fb308835512275267e11a5482ede4ab45177434559a53c64a116aa19c84d65dcdb459aecd3fc5587cb13e21cd2f196a0078 SHA512 3d7695f27b7909eb82f05527ab7551fe90a85a70f20ea980293b59672a62f9b015966180407fa0786e94b01ad1d1acfaa7d40426bb63410efd24a144e559e2f0
diff --git a/dev-python/pyopenssl/pyopenssl-22.0.0.ebuild b/dev-python/pyopenssl/pyopenssl-22.0.0.ebuild
new file mode 100644
index 000000000000..ddce54532d60
--- /dev/null
+++ b/dev-python/pyopenssl/pyopenssl-22.0.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 toolchain-funcs
+
+MY_PN=pyOpenSSL
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Python interface to the OpenSSL library"
+HOMEPAGE="
+ https://www.pyopenssl.org/
+ https://pypi.org/project/pyOpenSSL/
+ https://github.com/pyca/pyopenssl/
+"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/cryptography-35.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx doc \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+src_configure() {
+ # test for 32-bit time_t
+ "$(tc-getCC)" ${CFLAGS} ${CPPFLAGS} -c -x c - -o /dev/null <<-EOF &>/dev/null
+ #include <sys/types.h>
+ int test[sizeof(time_t) >= 8 ? 1 : -1];
+ EOF
+
+ if [[ ${?} -eq 0 ]]; then
+ PYOPENSSL_SKIP_LARGE_TIME=
+ einfo "time_t is at least 64-bit long"
+ else
+ PYOPENSSL_SKIP_LARGE_TIME=1
+ einfo "time_t is smaller than 64 bits, will skip broken tests"
+ fi
+}
+
+python_test() {
+ local -x TZ=UTC
+ local EPYTEST_DESELECT=(
+ tests/test_ssl.py::TestContext::test_set_default_verify_paths
+ )
+ [[ ${PYOPENSSL_SKIP_LARGE_TIME} ]] && EPYTEST_DESELECT+=(
+ tests/test_crypto.py::TestX509StoreContext::test_verify_with_time
+ )
+
+ epytest
+}