summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-17 13:28:43 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-17 14:19:26 +0200
commit71a22e500634ea1531a3cb0c59dea725fc294820 (patch)
tree41ea2446e9b2b23ec4e2ef52f2e16fad0285f281 /dev-python/pymdown-lexers/pymdown-lexers-0_pre20210902.ebuild
parentdev-python/pymdown-extensions: enable py3.11 (diff)
downloadgentoo-71a22e500634ea1531a3cb0c59dea725fc294820.tar.gz
gentoo-71a22e500634ea1531a3cb0c59dea725fc294820.tar.bz2
gentoo-71a22e500634ea1531a3cb0c59dea725fc294820.zip
dev-python/pymdown-lexers: add 0_pre20210902
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/pymdown-lexers/pymdown-lexers-0_pre20210902.ebuild')
-rw-r--r--dev-python/pymdown-lexers/pymdown-lexers-0_pre20210902.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pymdown-lexers/pymdown-lexers-0_pre20210902.ebuild b/dev-python/pymdown-lexers/pymdown-lexers-0_pre20210902.ebuild
new file mode 100644
index 000000000000..43e9cae5bf38
--- /dev/null
+++ b/dev-python/pymdown-lexers/pymdown-lexers-0_pre20210902.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+COMMIT="4cd030ad37bedff37345b37c1f1cd118530429ed"
+
+DESCRIPTION="Additional lexers for use in Pygments"
+HOMEPAGE="https://github.com/facelessuser/pymdown-lexers"
+SRC_URI="https://github.com/facelessuser/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pygments-2.0.1[${PYTHON_USEDEP}]
+"