summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-14 17:07:18 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-14 18:04:25 +0100
commit3bdd7bd2c431d554bb81143bf3bdb665e840cd5f (patch)
tree7e7f58d63e9505e1bb03e97e39c4b4e6491428cc /dev-python/pylama
parentdev-python/mypy: Bump to 0.940 (diff)
downloadgentoo-3bdd7bd2c431d554bb81143bf3bdb665e840cd5f.tar.gz
gentoo-3bdd7bd2c431d554bb81143bf3bdb665e840cd5f.tar.bz2
gentoo-3bdd7bd2c431d554bb81143bf3bdb665e840cd5f.zip
dev-python/pylama: Bump to 8.3.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylama')
-rw-r--r--dev-python/pylama/Manifest1
-rw-r--r--dev-python/pylama/pylama-8.3.8.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pylama/Manifest b/dev-python/pylama/Manifest
index 2ad1c2501078..4c933257f85a 100644
--- a/dev-python/pylama/Manifest
+++ b/dev-python/pylama/Manifest
@@ -1 +1,2 @@
DIST pylama-8.3.7.tar.gz 36264 BLAKE2B 8092320c039b5cd45a379a2718443cf03f5cef931767ae765c90096e3b23d5b7242034009eecb40413f05e2de2fd72a4285a91ebbc1fb474d232cffc9c992b94 SHA512 acfab9584e7bd8b146350e6af83975e91391e39c00a0fea23d4e55f46dd684b519088ed68c90e335e334e8526aecab2ad2286a0c082d26a4b867eadcbd8866c8
+DIST pylama-8.3.8.tar.gz 36319 BLAKE2B 5251bd32549793a8d06b6180a3e4f4c20f23dbdfecc146eb877222995bcadcf8cf8343f99ad897fb3e00c0f455762f82f4e3d157c34be6f21b4f220e87b636a2 SHA512 b55d7cb28a94f19270bde7ff6a8d760ef9132c845aaa85340271e42af6987fcc919ba9b0ddaebb6da6c1ffe789aaf39c83d273f8adea88db58a9218577899924
diff --git a/dev-python/pylama/pylama-8.3.8.ebuild b/dev-python/pylama/pylama-8.3.8.ebuild
new file mode 100644
index 000000000000..c76cee480c89
--- /dev/null
+++ b/dev-python/pylama/pylama-8.3.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Code audit tool for python"
+HOMEPAGE="https://github.com/klen/pylama"
+SRC_URI="https://github.com/klen/pylama/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/mccabe-0.6.1[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pydocstyle-6.1.1[${PYTHON_USEDEP}]
+ >=dev-python/pyflakes-2.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/eradicate[${PYTHON_USEDEP}]
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/pylint[${PYTHON_USEDEP}]
+ dev-python/radon[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # not packaged
+ tests/test_linters.py::test_quotes
+ tests/test_linters.py::test_vulture
+)