summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-07-07 21:57:29 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-07-07 21:59:34 +0300
commitcd7eb5afe6bafa2b2deb48edc606428f0823a39c (patch)
treed6512d16c49049950c5a61e1b1ace3ccfd6edae9 /dev-python/pygit2
parentsys-apps/syd: drop 3.22.0, 3.23.4 (diff)
downloadgentoo-cd7eb5afe6bafa2b2deb48edc606428f0823a39c.tar.gz
gentoo-cd7eb5afe6bafa2b2deb48edc606428f0823a39c.tar.bz2
gentoo-cd7eb5afe6bafa2b2deb48edc606428f0823a39c.zip
dev-python/pygit2: add 1.15.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pygit2')
-rw-r--r--dev-python/pygit2/Manifest1
-rw-r--r--dev-python/pygit2/pygit2-1.15.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pygit2/Manifest b/dev-python/pygit2/Manifest
index 16eb0caf46fa..59478253e7a7 100644
--- a/dev-python/pygit2/Manifest
+++ b/dev-python/pygit2/Manifest
@@ -1,2 +1,3 @@
DIST pygit2-1.14.1.tar.gz 765621 BLAKE2B 7761851052c5dc03f82db987166012eb2a3445d62b209bc1734e240a619d7c5e4449c1772b250dd3ba8e1605b7c94edb4d8b7ad50c92bd85833e4688ed1e92ef SHA512 0718d7f480d40a5c435c725fbfec728ebdbb70d700607662308458dd125796fce9ddcf40afa6841ddc9cb7b19a5966fb3b5c8e4a52281a7eb354381ce62b5534
DIST pygit2-1.15.0.tar.gz 766816 BLAKE2B bc0f97cbcdb1c445bb00706ade517f4c36cf9d869f87ca919df8116fb3a4e9f29a1c43a637ae53b7e6ccfad028e0df48fad85ee1a0f334438c3fa2916247fbda SHA512 33a5805046f5f18de2ec212145f4adf26b28afb11b669e3cb4d1dc29362ea6627fde605b654d11a80d91589e3000784dfe1c79522bd8c6f1b27974b13a15ef07
+DIST pygit2-1.15.1.tar.gz 768818 BLAKE2B ca418afc24a680cbfddee00ec9b6c8f4987ad65abd3d61b56cfc1682ce97a3685654f7663857a2a996c2c4f393ef2addfd336c5f5f548f3a1860056ba998bb40 SHA512 4795dbc7b05000955fea86e1b51209a77dfaf99ea806aa8a2be538aed8094638def3e15b0507c61ab57cad2b8e5faee7f1c90ce5c2b20094f972638e7c9bd20f
diff --git a/dev-python/pygit2/pygit2-1.15.1.ebuild b/dev-python/pygit2/pygit2-1.15.1.ebuild
new file mode 100644
index 000000000000..a016ef984b26
--- /dev/null
+++ b/dev-python/pygit2/pygit2-1.15.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="
+ https://github.com/libgit2/pygit2/
+ https://pypi.org/project/pygit2/
+"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+DEPEND="
+ <dev-libs/libgit2-1.9:=
+ >=dev-libs/libgit2-1.8.1:=
+"
+BDEPEND="
+ >=dev-python/cffi-1.16.0:=[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ ${BDEPEND}
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # unconditionally prevent it from using network
+ sed -i -e '/has_network/s:True:False:' test/utils.py || die
+}
+
+src_test() {
+ rm -r pygit2 || die
+ distutils-r1_src_test
+}