summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-27 05:03:11 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-27 05:54:47 +0200
commit1ca1ccd63c699609ef775b0edf889ee9aa6932bf (patch)
tree76234f1b0b3aa4884c39a37eba4c66cf6b11c28a /dev-python/pygit2
parentdev-python/hypothesis: Bump to 6.79.3 (diff)
downloadgentoo-1ca1ccd63c699609ef775b0edf889ee9aa6932bf.tar.gz
gentoo-1ca1ccd63c699609ef775b0edf889ee9aa6932bf.tar.bz2
gentoo-1ca1ccd63c699609ef775b0edf889ee9aa6932bf.zip
dev-python/pygit2: Bump to 1.12.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pygit2')
-rw-r--r--dev-python/pygit2/Manifest1
-rw-r--r--dev-python/pygit2/pygit2-1.12.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pygit2/Manifest b/dev-python/pygit2/Manifest
index 9ace7df0ec90..a95ac8ad476c 100644
--- a/dev-python/pygit2/Manifest
+++ b/dev-python/pygit2/Manifest
@@ -1,2 +1,3 @@
DIST pygit2-1.12.0.tar.gz 737533 BLAKE2B 4989587e2f7cc7041e65e1080ec4eea4d749c7dcc8b8cac45e3753902d477dd2fb30f3bdb5ff73860baf587ed808bbb2c08afb3b6054bbd094fee2f7c573aab7 SHA512 885984d8bb990ca3f60024c3db10d5f0bc77939382e93ab469f77b676bd95e6f44238d7e5d08dd9d17094a45cb0880dda94b860b014607f64a23a85db60b0422
DIST pygit2-1.12.1.tar.gz 738390 BLAKE2B 0d22cfb84cf62af32a1da76feb76da0c42ff30ae17bc9881c32553c662ac67a27bad57f545034dc1f42ef9844846b556f92b5b0e0faee63bb524dc57e73d4f9c SHA512 97f7cef7eeac3f165df8d82933854f53f842565efd764c351812ab27f35d574da9eb37628740f878540ad0be0447ad83a2ae0ed1544c615ba29485f08dd345c5
+DIST pygit2-1.12.2.tar.gz 738453 BLAKE2B 805472147021296b28f0d47f97e5b42355e2f8eb418cc48134a8c2a0c606e04bdf6ee9ddd5586949652b36d921631aaa16fb739d8491db01196c7ecb26f2ea13 SHA512 adf82f385b0cb8e239113171e7e4d75d4902828b18a04f2624c6931f7d11648ae0503d615ef5d89ddc477b94c5ac48354be223e2bde7d4c111a957e114b6a28d
diff --git a/dev-python/pygit2/pygit2-1.12.2.ebuild b/dev-python/pygit2/pygit2-1.12.2.ebuild
new file mode 100644
index 000000000000..adafd17ad091
--- /dev/null
+++ b/dev-python/pygit2/pygit2-1.12.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="
+ https://github.com/libgit2/pygit2/
+ https://pypi.org/project/pygit2/
+"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+DEPEND="
+ =dev-libs/libgit2-1.6*:=
+"
+BDEPEND="
+ >=dev-python/cffi-1.9.1:=[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ ${BDEPEND}
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # unconditionally prevent it from using network
+ sed -i -e '/has_network/s:True:False:' test/utils.py || die
+}
+
+src_test() {
+ rm -r pygit2 || die
+ distutils-r1_src_test
+}