summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyfire
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyfire')
-rw-r--r--dev-python/pyfire/Manifest1
-rw-r--r--dev-python/pyfire/metadata.xml11
-rw-r--r--dev-python/pyfire/pyfire-0.3.4-r1.ebuild23
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pyfire/Manifest b/dev-python/pyfire/Manifest
new file mode 100644
index 000000000000..da9c98adf38d
--- /dev/null
+++ b/dev-python/pyfire/Manifest
@@ -0,0 +1 @@
+DIST pyfire-0.3.4.tar.gz 15432 SHA256 cd7518f9277080423960205bc7b673648c939f250ad8f3e8d743b582a73ca963 SHA512 91dac47595b74cd1275f3c4e6e9717447605eb7576a94f2478b33de42e8d9e12f147a3759aec6801bb590cb8fe366cd23dfa0544adffea6dccd93ffe4ff399a8 WHIRLPOOL 9c395685e1d87e921e348ca8c59c9145928928b7678d61a5081be3d02e407b558a9292a1fae0334eb53bd0ff8ef8741621f18159d83015f2225758590bce393e
diff --git a/dev-python/pyfire/metadata.xml b/dev-python/pyfire/metadata.xml
new file mode 100644
index 000000000000..ac05301984fa
--- /dev/null
+++ b/dev-python/pyfire/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pyfire</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyfire/pyfire-0.3.4-r1.ebuild b/dev-python/pyfire/pyfire-0.3.4-r1.ebuild
new file mode 100644
index 000000000000..f067827a2277
--- /dev/null
+++ b/dev-python/pyfire/pyfire-0.3.4-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+DESCRIPTION="A python implementation of the Campfire API"
+HOMEPAGE="http://www.pyfire.org/"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/twisted-web[${PYTHON_USEDEP}]
+"