summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2020-09-02 19:14:23 +0200
committerHanno Böck <hanno@gentoo.org>2020-09-02 19:14:23 +0200
commit7517a9ba96480dfd157c766bed2f4a9bbd140aa6 (patch)
tree52638c6f2827f2aec7222215a6460ed8467dbb4d /dev-python/pyClamd
parentapp-vim/pydoc: add python3_7 and python3_8 to PYTHON_TARGETS. (diff)
downloadgentoo-7517a9ba96480dfd157c766bed2f4a9bbd140aa6.tar.gz
gentoo-7517a9ba96480dfd157c766bed2f4a9bbd140aa6.tar.bz2
gentoo-7517a9ba96480dfd157c766bed2f4a9bbd140aa6.zip
dev-python/pyClamd: Python 3.8/3.9 support.
Bump EAPI to 7. Signed-off-by: Hanno Böck <hanno@gentoo.org> Package-Manager: Portage-3.0.5, Repoman-3.0.1
Diffstat (limited to 'dev-python/pyClamd')
-rw-r--r--dev-python/pyClamd/pyClamd-0.4.0-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pyClamd/pyClamd-0.4.0-r2.ebuild b/dev-python/pyClamd/pyClamd-0.4.0-r2.ebuild
new file mode 100644
index 000000000000..ac100d23389d
--- /dev/null
+++ b/dev-python/pyClamd/pyClamd-0.4.0-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="python interface to Clamd (Clamav daemon)"
+HOMEPAGE="https://xael.org/pages/pyclamd-en.html"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -e 's:/etc/clamav/clamd.conf:/etc/clamd.conf:' \
+ -i pyclamd/pyclamd.py || die
+}