summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-01-27 14:34:10 -0500
committerVirgil Dupras <vdupras@gentoo.org>2019-01-27 14:34:10 -0500
commit3d810e85e598bb0374d2b3fa2c3d8b9eadea7e96 (patch)
tree6036915f527cfe137a6de42fce2546629a7a41c2 /dev-python/pluggy
parentdev-ruby/rack-attack: cleanup (diff)
downloadgentoo-3d810e85e598bb0374d2b3fa2c3d8b9eadea7e96.tar.gz
gentoo-3d810e85e598bb0374d2b3fa2c3d8b9eadea7e96.tar.bz2
gentoo-3d810e85e598bb0374d2b3fa2c3d8b9eadea7e96.zip
dev-python/pluggy: disable failing test under pypy3
Closes: https://bugs.gentoo.org/648672 Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-python/pluggy')
-rw-r--r--dev-python/pluggy/files/pluggy-0.7.1-disable-broken-tests.patch19
-rw-r--r--dev-python/pluggy/pluggy-0.7.1.ebuild6
2 files changed, 24 insertions, 1 deletions
diff --git a/dev-python/pluggy/files/pluggy-0.7.1-disable-broken-tests.patch b/dev-python/pluggy/files/pluggy-0.7.1-disable-broken-tests.patch
new file mode 100644
index 000000000000..578b56ce3467
--- /dev/null
+++ b/dev-python/pluggy/files/pluggy-0.7.1-disable-broken-tests.patch
@@ -0,0 +1,19 @@
+diff --git a/testing/test_helpers.py b/testing/test_helpers.py
+index 846b0a1..89a52b1 100644
+--- a/testing/test_helpers.py
++++ b/testing/test_helpers.py
+@@ -1,3 +1,4 @@
++import platform
+ from pluggy.hooks import varnames
+ from pluggy.manager import _formatdef
+
+@@ -27,6 +28,9 @@ def test_varnames_default():
+
+
+ def test_varnames_class():
++ # fails under pypy3
++ if platform.python_implementation() == 'PyPy':
++ return
+ class C(object):
+ def __init__(self, x):
+ pass
diff --git a/dev-python/pluggy/pluggy-0.7.1.ebuild b/dev-python/pluggy/pluggy-0.7.1.ebuild
index 2ccc546cb187..dd9526ce4e72 100644
--- a/dev-python/pluggy/pluggy-0.7.1.ebuild
+++ b/dev-python/pluggy/pluggy-0.7.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -23,6 +23,10 @@ DEPEND="${RDEPEND}
dev-python/pytest[${PYTHON_USEDEP}]
)"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.7.1-disable-broken-tests.patch"
+)
+
python_test() {
PYTHONPATH="${BUILD_DIR}/lib" pytest -v || die "tests failed with ${EPYTHON}"
}