summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-13 19:51:07 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-13 19:51:07 +0100
commit77dbf5cbf1b2c87adbfd23e3fd7866a821fa12d3 (patch)
tree83e9d8ee224b94b938d7e6df613bee7f471aa0bb /dev-python/platformdirs
parentdev-python/sphinxcontrib-spelling: Bump to 7.7.0 (diff)
downloadgentoo-77dbf5cbf1b2c87adbfd23e3fd7866a821fa12d3.tar.gz
gentoo-77dbf5cbf1b2c87adbfd23e3fd7866a821fa12d3.tar.bz2
gentoo-77dbf5cbf1b2c87adbfd23e3fd7866a821fa12d3.zip
dev-python/platformdirs: Bump to 2.5.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/platformdirs')
-rw-r--r--dev-python/platformdirs/Manifest1
-rw-r--r--dev-python/platformdirs/platformdirs-2.5.4.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/platformdirs/Manifest b/dev-python/platformdirs/Manifest
index 29eac4e09f13..2c02b2288620 100644
--- a/dev-python/platformdirs/Manifest
+++ b/dev-python/platformdirs/Manifest
@@ -1,2 +1,3 @@
DIST platformdirs-2.5.2.gh.tar.gz 20335 BLAKE2B 5d11e39d3e7482646e90d57642f0a956633408de5ec9f3cc1954e451ebb3bc3234a453c1e62997bcc74a32082f5d044a1e68ef6d7e75e27876495ad6ffb3c8f5 SHA512 7162050adff66124601359f0c1f73e671444d286e9f00c2694647df233c25e1eae673baf829e3e74e2a54d15a1633d0202dba986d4ed8a2864fc47859af0fd4e
DIST platformdirs-2.5.3.gh.tar.gz 20644 BLAKE2B db8411c06ddf6cf5628aca2b828654293430cff0db36df5cfddebee2bd10122a50aa66f5c6f724f8f051f8745a0c85a00d59b12778f4478b6632d2d088d2c266 SHA512 9a44673a1f5ce7f3197843c35fb7972baeb7ad586bbf5751b7185aca2ae62fc0e467df13247d57884c68e90db4ef6e96b73744b1528d9c1b3f4c90874fc9c538
+DIST platformdirs-2.5.4.gh.tar.gz 20645 BLAKE2B c995b881bf25d215ffbcfa4d9fd6721d763d2c27e306961965cd16da00bffce5a1e8dc3ebb48f0f499dbc0f5a079fcffbe0755913f61bc3e8a7192e951e8f18b SHA512 35e2f4ff4d289d6d83172105c716b3a337dc55b52be6d4ac653460e6e5696cce2256a645b2e91a8bab4a17f8a6c6e49b4a005924ede8da7ef2d03ede35061703
diff --git a/dev-python/platformdirs/platformdirs-2.5.4.ebuild b/dev-python/platformdirs/platformdirs-2.5.4.ebuild
new file mode 100644
index 000000000000..8a195e51326b
--- /dev/null
+++ b/dev-python/platformdirs/platformdirs-2.5.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A small Python module for determining appropriate platform-specific dirs"
+HOMEPAGE="
+ https://pypi.org/project/platformdirs/
+ https://github.com/platformdirs/platformdirs/
+"
+SRC_URI="
+ https://github.com/platformdirs/platformdirs/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}