summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-29 09:56:25 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-29 10:02:58 +0200
commit9422b5b7314708d4c3d73e90bea5a3af95bb7dcc (patch)
treeae68c536fa732674aea456afb8a7e843307994f1 /dev-python/pip/files
parentdev-python/pip: Unblock --prefix installs (diff)
downloadgentoo-9422b5b7314708d4c3d73e90bea5a3af95bb7dcc.tar.gz
gentoo-9422b5b7314708d4c3d73e90bea5a3af95bb7dcc.tar.bz2
gentoo-9422b5b7314708d4c3d73e90bea5a3af95bb7dcc.zip
dev-python/pip: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pip/files')
-rw-r--r--dev-python/pip/files/pip-19.3.1-network-tests.patch66
-rw-r--r--dev-python/pip/files/pip-19.3.1-r2-disable-system-install.patch17
-rw-r--r--dev-python/pip/files/pip-9.0.1-disable-version-check.patch32
-rw-r--r--dev-python/pip/files/pip-disable-system-install.patch29
4 files changed, 0 insertions, 144 deletions
diff --git a/dev-python/pip/files/pip-19.3.1-network-tests.patch b/dev-python/pip/files/pip-19.3.1-network-tests.patch
deleted file mode 100644
index f194a7b34a90..000000000000
--- a/dev-python/pip/files/pip-19.3.1-network-tests.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-diff --git a/news/7359.trivial b/news/7359.trivial
-new file mode 100644
-index 000000000..e69de29bb
-diff --git a/tests/functional/test_freeze.py b/tests/functional/test_freeze.py
-index d13c931d0..2e35de3e6 100644
---- a/tests/functional/test_freeze.py
-+++ b/tests/functional/test_freeze.py
-@@ -721,6 +721,7 @@ def test_freeze_user(script, virtualenv, data):
- assert 'simple2' not in result.stdout
-
-
-+@pytest.mark.network
- def test_freeze_path(tmpdir, script, data):
- """
- Test freeze with --path.
-@@ -734,5 +735,6 @@ def test_freeze_path(tmpdir, script, data):
- _check_output(result.stdout, expected)
-
-
-+@pytest.mark.network
- def test_freeze_path_exclude_user(tmpdir, script, data):
- """
-@@ -756,6 +758,7 @@ def test_freeze_path_exclude_user(tmpdir, script, data):
- _check_output(result.stdout, expected)
-
-
-+@pytest.mark.network
- def test_freeze_path_multiple(tmpdir, script, data):
- """
- Test freeze with multiple --path arguments.
-diff --git a/tests/functional/test_install.py b/tests/functional/test_install.py
-index a9eff081d..ba7a0a55c 100644
---- a/tests/functional/test_install.py
-+++ b/tests/functional/test_install.py
-@@ -1325,6 +1325,7 @@ def test_install_no_binary_disables_building_wheels(script, data, with_wheel):
- assert "Running setup.py install for upper" in str(res), str(res)
-
-
-+@pytest.mark.network
- def test_install_no_binary_builds_pep_517_wheel(script, data, with_wheel):
- to_install = data.packages.joinpath('pep517_setup_and_pyproject')
- res = script.pip(
-diff --git a/tests/functional/test_install_config.py b/tests/functional/test_install_config.py
-index 176976c4e..308263928 100644
---- a/tests/functional/test_install_config.py
-+++ b/tests/functional/test_install_config.py
-@@ -133,6 +133,7 @@ def test_command_line_appends_correctly(script, data):
- ), 'stdout: {}'.format(result.stdout)
-
-
-+@pytest.mark.network
- def test_config_file_override_stack(script, virtualenv):
- """
- Test config files (global, overriding a global config with a
-diff --git a/tests/functional/test_install_upgrade.py b/tests/functional/test_install_upgrade.py
-index 6d2eeb5dc..0024de4d4 100644
---- a/tests/functional/test_install_upgrade.py
-+++ b/tests/functional/test_install_upgrade.py
-@@ -8,6 +8,7 @@
- from tests.lib.local_repos import local_checkout
-
-
-+@pytest.mark.network
- def test_no_upgrade_unless_requested(script):
- """
- No upgrade if not specifically requested.
diff --git a/dev-python/pip/files/pip-19.3.1-r2-disable-system-install.patch b/dev-python/pip/files/pip-19.3.1-r2-disable-system-install.patch
deleted file mode 100644
index 8486c37f0c73..000000000000
--- a/dev-python/pip/files/pip-19.3.1-r2-disable-system-install.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-install: Raise an error to avoid breaking python-exec
-
-Running pip without --target, --root, or --user will result in packages
-being installed systemwide. This has a tendency to break python-exec if
-setuptools gets installed or upgraded.
-
---- pip-19.1/src/pip/_internal/commands/install.py
-+++ pip-19.1/src/pip/_internal/commands/install.py
-@@ -246,6 +246,9 @@ class InstallCommand(RequirementCommand):
- if options.upgrade:
- upgrade_strategy = options.upgrade_strategy
-
-+ if not options.use_user_site and not options.target_dir and not options.root_path and not os.getenv('GENTOO_PIP_TESTING'):
-+ raise CommandError("(Gentoo) Please run pip with the --user option to avoid breaking python-exec")
-+
- if options.build_dir:
- options.build_dir = os.path.abspath(options.build_dir)
diff --git a/dev-python/pip/files/pip-9.0.1-disable-version-check.patch b/dev-python/pip/files/pip-9.0.1-disable-version-check.patch
deleted file mode 100644
index 7334380c1e1d..000000000000
--- a/dev-python/pip/files/pip-9.0.1-disable-version-check.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 890a1c26018752f2c57c7800968e4b8d1e0987f9 Mon Sep 17 00:00:00 2001
-From: Sebastian Pipping <sebastian@pipping.org>
-Date: Sun, 20 Nov 2016 19:52:40 +0100
-Subject: [PATCH] Stop checking for new versions
-
----
- pip/basecommand.py | 9 ---------
- 1 file changed, 9 deletions(-)
-
-diff --git a/pip/basecommand.py b/pip/basecommand.py
-index 54c6706..3cffe86 100644
---- a/pip/basecommand.py
-+++ b/pip/basecommand.py
-@@ -241,15 +241,6 @@ class Command(object):
- logger.critical('Exception:', exc_info=True)
-
- return UNKNOWN_ERROR
-- finally:
-- # Check if we're using the latest version of pip available
-- if (not options.disable_pip_version_check and not
-- getattr(options, "no_index", False)):
-- with self._build_session(
-- options,
-- retries=0,
-- timeout=min(5, options.timeout)) as session:
-- pip_version_check(session)
-
- return SUCCESS
-
---
-2.10.2
-
diff --git a/dev-python/pip/files/pip-disable-system-install.patch b/dev-python/pip/files/pip-disable-system-install.patch
deleted file mode 100644
index 9e572454315e..000000000000
--- a/dev-python/pip/files/pip-disable-system-install.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 847553da616edabede18c69ba640a32b719b45a8 Mon Sep 17 00:00:00 2001
-From: Mike Gilbert <floppym@gentoo.org>
-Date: Tue, 27 Oct 2015 12:20:44 -0400
-Subject: [PATCH] install: Raise an error to avoid breaking python-exec
-
-Running pip without --target, --root, or --user will result in packages
-being installed systemwide. This has a tendency to break python-exec if
-setuptools gets installed or upgraded.
----
- pip/commands/install.py | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/pip/commands/install.py b/pip/commands/install.py
-index 46cd9f2..36b72f2 100644
---- a/pip/commands/install.py
-+++ b/pip/commands/install.py
-@@ -204,6 +204,9 @@ class InstallCommand(RequirementCommand):
- )
- options.ignore_installed = True
-
-+ if not options.use_user_site and not options.target_dir and not options.root_path:
-+ raise CommandError("(Gentoo) Please run pip with the --user option to avoid breaking python-exec")
-+
- if options.build_dir:
- options.build_dir = os.path.abspath(options.build_dir)
-
---
-2.6.2
-