summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2020-12-03 23:51:09 +0700
committerAndrey Grozin <grozin@gentoo.org>2020-12-03 23:51:09 +0700
commite135f7405a201a552bdaeea9bf29f6cb75055ac2 (patch)
treeb7c80134505908ff1c0e7e8e7d0aa9175db7fda0 /dev-python/pikepdf
parentdev-python/pikepdf: fix dependencies (diff)
downloadgentoo-e135f7405a201a552bdaeea9bf29f6cb75055ac2.tar.gz
gentoo-e135f7405a201a552bdaeea9bf29f6cb75055ac2.tar.bz2
gentoo-e135f7405a201a552bdaeea9bf29f6cb75055ac2.zip
dev-python/pikepdf: clean 2.2.0
Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-python/pikepdf')
-rw-r--r--dev-python/pikepdf/pikepdf-2.2.0.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/pikepdf/pikepdf-2.2.0.ebuild b/dev-python/pikepdf/pikepdf-2.2.0.ebuild
deleted file mode 100644
index 39f8d8d20e67..000000000000
--- a/dev-python/pikepdf/pikepdf-2.2.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6..9} )
-inherit distutils-r1
-
-DESCRIPTION="Python library to work with pdf files based on qpdf"
-HOMEPAGE="https://pypi.org/project/pikepdf/ https://github.com/pikepdf/pikepdf"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="app-text/qpdf:0=
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/pybind11[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- >=dev-python/wheel-0.35[${PYTHON_USEDEP}]
- >=dev-python/pybind11-2.6.0[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-4.1[${PYTHON_USEDEP}]
- dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
- test? ( >=dev-python/attrs-20.2.0[${PYTHON_USEDEP}]
- >=dev-python/hypothesis-5[${PYTHON_USEDEP}]
- <dev-python/hypothesis-6.0[${PYTHON_USEDEP}]
- >=dev-python/pillow-5.0.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-6[${PYTHON_USEDEP}]
- <dev-python/pytest-7[${PYTHON_USEDEP}]
- >=dev-python/pytest-cov-2.10.1[${PYTHON_USEDEP}]
- <dev-python/pytest-cov-3[${PYTHON_USEDEP}]
- >=dev-python/pytest-xdist-1.28[${PYTHON_USEDEP}]
- <dev-python/pytest-xdist-2.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-timeout-1.4.2[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.8.0[${PYTHON_USEDEP}]
- >=dev-python/python-xmp-toolkit-2.0.1[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.8.3-test.patch )
-
-python_test() {
- pytest
-}
-
-# When ipython and matplotlib will get python3_8 support, we'll be able to add
-#
-#IUSE="doc"
-#DEPEND="doc? ( dev-python/ipython
-# dev-python/matplotlib
-# dev-python/sphinx-1.4
-# dev-python/sphinx_rtd_theme )"
-#python_compile_all() {
-# use doc && emake -C docs html
-#}
-#python_install_all() {
-# use doc && local HTML_DOCS=( docs/_build/html/. )
-# distutils-r1_python_install_all
-#}