summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-11-25 21:02:47 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-11-25 21:02:47 +0200
commite5de7f34ed71cb138de4265e053ff52693e98021 (patch)
tree54aaee00d7578dd6819a45ec84d644a4f39c813f /dev-python/pexpect
parentdev-python/mkdocs-pymdownx-material-extras: add 2.5.6 (diff)
downloadgentoo-e5de7f34ed71cb138de4265e053ff52693e98021.tar.gz
gentoo-e5de7f34ed71cb138de4265e053ff52693e98021.tar.bz2
gentoo-e5de7f34ed71cb138de4265e053ff52693e98021.zip
dev-python/pexpect: add 4.9.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pexpect')
-rw-r--r--dev-python/pexpect/Manifest1
-rw-r--r--dev-python/pexpect/pexpect-4.9.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pexpect/Manifest b/dev-python/pexpect/Manifest
index f26be5381a34..8ea51df2cd4c 100644
--- a/dev-python/pexpect/Manifest
+++ b/dev-python/pexpect/Manifest
@@ -1 +1,2 @@
DIST pexpect-4.8.0_p20230402.gh.tar.gz 169420 BLAKE2B 4780621f5876506c5ad2dbf03656d8c336d5aadef99b1ae99e841b5d0a945ab54177cb04a79b526e422cd4df7393c723000e4a28960bd5f57a5e0173b0a3bc69 SHA512 72cdf226ec5c7d60a10fbcecf81cd1ae422467652e104bb818908bf6d1a4a4bcadab9a06d58475a9609580d973956e18e2ab144ab13a0b700072474ff3087259
+DIST pexpect-4.9.0.tar.gz 166450 BLAKE2B a08e10deb9f21e49a04021d78dc1ff6c9eeded5825ef73b236c3dac725e6877a4fe74deaa6844c8aa4b1beab4b915d7612e682529c4ed97b364a737a1960b30f SHA512 0e4b3a6978b94aee221ff23cd7bd771517e0e0f1a1a8b17f77f15bf78edd3130ad093d925b7d1e86fe6ba7eb956205d4c616b4e52b2fcfa1e944d4860dd7b3a0
diff --git a/dev-python/pexpect/pexpect-4.9.0.ebuild b/dev-python/pexpect/pexpect-4.9.0.ebuild
new file mode 100644
index 000000000000..ed1001b2380c
--- /dev/null
+++ b/dev-python/pexpect/pexpect-4.9.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python module for spawning child apps and responding to expected patterns"
+HOMEPAGE="
+ https://pexpect.readthedocs.io/
+ https://pypi.org/project/pexpect/
+ https://github.com/pexpect/pexpect/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/ptyprocess-0.5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc \
+ dev-python/sphinxcontrib-github-alt
+
+src_test() {
+ # workaround new readline defaults
+ echo "set enable-bracketed-paste off" > "${T}"/inputrc || die
+ local -x INPUTRC="${T}"/inputrc
+ local EPYTEST_DESELECT=(
+ # flaky test on weaker arches
+ tests/test_performance.py
+ # requires zsh installed, not worth it
+ tests/test_replwrap.py::REPLWrapTestCase::test_zsh
+ )
+ distutils-r1_src_test
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}