summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-15 22:45:07 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-15 22:45:07 -0600
commit30e1c05a72b092d37e7e9a0f0cd97aa46662de7c (patch)
treedae38fd1fc2f28541fd72043a3fe8e4e4f33939d /dev-python/os-client-config/os-client-config-1.29.0.ebuild
parentdev-python/requestsexceptions: 1.4.0 bup (diff)
downloadgentoo-30e1c05a72b092d37e7e9a0f0cd97aa46662de7c.tar.gz
gentoo-30e1c05a72b092d37e7e9a0f0cd97aa46662de7c.tar.bz2
gentoo-30e1c05a72b092d37e7e9a0f0cd97aa46662de7c.zip
dev-python/os-client-config: 1.29.0 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/os-client-config/os-client-config-1.29.0.ebuild')
-rw-r--r--dev-python/os-client-config/os-client-config-1.29.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/os-client-config/os-client-config-1.29.0.ebuild b/dev-python/os-client-config/os-client-config-1.29.0.ebuild
new file mode 100644
index 000000000000..befab13b638f
--- /dev/null
+++ b/dev-python/os-client-config/os-client-config-1.29.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Client Configuation Library"
+HOMEPAGE="http://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.8.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/appdirs-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/requestsexceptions-1.1.1[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}"/test_get_all_clouds.patch
+)
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}