summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-24 06:25:11 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-24 08:15:31 +0200
commit965af87a1eb39f656cfc0bb4bca72fca564c8286 (patch)
treea4bcd109d86d7268e62eb95d84cf0ff1ead3cd18 /dev-python/openapi-schema-validator
parentdev-python/nuitka: Bump to 0.8.1 (diff)
downloadgentoo-965af87a1eb39f656cfc0bb4bca72fca564c8286.tar.gz
gentoo-965af87a1eb39f656cfc0bb4bca72fca564c8286.tar.bz2
gentoo-965af87a1eb39f656cfc0bb4bca72fca564c8286.zip
dev-python/openapi-schema-validator: New package, v0.2.3
Needed by openapi-spec-validator that is a new dependency of dev-python/moto. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/openapi-schema-validator')
-rw-r--r--dev-python/openapi-schema-validator/Manifest1
-rw-r--r--dev-python/openapi-schema-validator/metadata.xml11
-rw-r--r--dev-python/openapi-schema-validator/openapi-schema-validator-0.2.3.ebuild37
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/openapi-schema-validator/Manifest b/dev-python/openapi-schema-validator/Manifest
new file mode 100644
index 000000000000..9d505ee9f4df
--- /dev/null
+++ b/dev-python/openapi-schema-validator/Manifest
@@ -0,0 +1 @@
+DIST openapi-schema-validator-0.2.3.gh.tar.gz 25501 BLAKE2B d961cabca647f59d4d4188f1941ce5b2475e02520bcc10e7cd29817c8ea8ebaaac5af1ffb0e3d5079ed2d1493414cdaf55336744b142385754585e748af8ac98 SHA512 e6dfe3d6cc99fa9723102ced42040203157639be68b0438d7bfae4499e51cdb6257a36dca10425a5d5e692cebb958468ebeee722116b99d800a6fcf972400c66
diff --git a/dev-python/openapi-schema-validator/metadata.xml b/dev-python/openapi-schema-validator/metadata.xml
new file mode 100644
index 000000000000..b4e6776314fc
--- /dev/null
+++ b/dev-python/openapi-schema-validator/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">p1c2u/openapi-schema-validator</remote-id>
+ <remote-id type="pypi">openapi-schema-validator</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/openapi-schema-validator/openapi-schema-validator-0.2.3.ebuild b/dev-python/openapi-schema-validator/openapi-schema-validator-0.2.3.ebuild
new file mode 100644
index 000000000000..89d06659d301
--- /dev/null
+++ b/dev-python/openapi-schema-validator/openapi-schema-validator-0.2.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenAPI schema validation for Python"
+HOMEPAGE="
+ https://github.com/p1c2u/openapi-schema-validator/
+ https://pypi.org/project/openapi-schema-validator/
+"
+SRC_URI="
+ https://github.com/p1c2u/openapi-schema-validator/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/isodate[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.0.0[${PYTHON_USEDEP}]
+ dev-python/rfc3339-validator[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/--cov/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}