summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-07 04:43:04 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-07 05:01:12 +0200
commit93e7f2e3a498d555495aaa0256ee48ff106ce007 (patch)
tree1b71a7634b3988ed10c52268705125cfcc7a007d /dev-python/mkdocstrings-python
parentdev-python/overrides: Bump to 7.4.0 (diff)
downloadgentoo-93e7f2e3a498d555495aaa0256ee48ff106ce007.tar.gz
gentoo-93e7f2e3a498d555495aaa0256ee48ff106ce007.tar.bz2
gentoo-93e7f2e3a498d555495aaa0256ee48ff106ce007.zip
dev-python/mkdocstrings-python: Bump to 1.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mkdocstrings-python')
-rw-r--r--dev-python/mkdocstrings-python/Manifest1
-rw-r--r--dev-python/mkdocstrings-python/mkdocstrings-python-1.3.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/mkdocstrings-python/Manifest b/dev-python/mkdocstrings-python/Manifest
index e9fa980a5f55..079a5b4942cd 100644
--- a/dev-python/mkdocstrings-python/Manifest
+++ b/dev-python/mkdocstrings-python/Manifest
@@ -1 +1,2 @@
DIST mkdocstrings-python-1.2.1.gh.tar.gz 132468 BLAKE2B 287cae20510818c085bf505fea0f74e39df86538e19bfcb90aa7f6d46fb237158979dc65c7f955d73461fadb4ed35263ef47b9771f224b5793026a9f0b3c86e1 SHA512 147849a88c3bb5347c1cb4293c9ee9c54cb33933bc274dc5bc933f72deb64016c7f7b8ba817311e282c68606d0980571d5713dec7a47e8d6c51168d524af7d97
+DIST mkdocstrings-python-1.3.0.gh.tar.gz 132776 BLAKE2B 894068067f301f40ed9535cd929fdbd40aa396c9c09c0cee7887f50669465cd0422c0b9b240553193df7e7d4c90f0bf2b591000e6568ee3c47256fc5d1f79179 SHA512 caf806d6285281ef84ed78bd6295ec6732d454a602f55f825436d0a17e9ab62e33ac21510d0ccee5d33fb3c117ec416859ad90ce75d608649a277342d1dc5a1c
diff --git a/dev-python/mkdocstrings-python/mkdocstrings-python-1.3.0.ebuild b/dev-python/mkdocstrings-python/mkdocstrings-python-1.3.0.ebuild
new file mode 100644
index 000000000000..17104df0a441
--- /dev/null
+++ b/dev-python/mkdocstrings-python/mkdocstrings-python-1.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=pdm-backend
+
+inherit distutils-r1
+
+DESCRIPTION="Python handler for dev-python/mkdocstrings"
+HOMEPAGE="
+ https://mkdocstrings.github.io/python/
+ https://github.com/mkdocstrings/python/
+ https://pypi.org/project/mkdocstrings-python/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ <dev-python/griffe-0.33[${PYTHON_USEDEP}]
+ >=dev-python/griffe-0.30.0[${PYTHON_USEDEP}]
+ dev-python/mkdocstrings[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}