summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-17 10:11:03 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-17 10:55:37 +0100
commit98df7e73bc8a1bb72a91748e1b5f296884661831 (patch)
treee4dbf8514f4983ff97ea22201cd95f25cd1aafec /dev-python/markdown
parentdev-python/fs: Bump to 2.4.14 (diff)
downloadgentoo-98df7e73bc8a1bb72a91748e1b5f296884661831.tar.gz
gentoo-98df7e73bc8a1bb72a91748e1b5f296884661831.tar.bz2
gentoo-98df7e73bc8a1bb72a91748e1b5f296884661831.zip
dev-python/markdown: Bump to 3.3.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/markdown')
-rw-r--r--dev-python/markdown/Manifest1
-rw-r--r--dev-python/markdown/markdown-3.3.5.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/markdown/Manifest b/dev-python/markdown/Manifest
index 83edaf19986b..e2bf72aa00c8 100644
--- a/dev-python/markdown/Manifest
+++ b/dev-python/markdown/Manifest
@@ -1 +1,2 @@
DIST Markdown-3.3.4.tar.gz 322192 BLAKE2B 37122305112440b85d7f0e5e1bf90bafe15a8bcb84e8d8bdd9b4183dcb4be1010d287450062bab7dc9017d8e618f84a8245e6fd35f8204e5e2ece14d302fb13b SHA512 37422619dd8f542bfcf7975c92e76a39e4eeeb42386727d52037869cee1617f8efcb74a382a9c7cb903907ebf3643a27ba0de583bc0dbd327a36e72bbf8520af
+DIST Markdown-3.3.5.tar.gz 323578 BLAKE2B df585dc664d885259c4d5039b74ca3181ea8d0ba50e3d3bd64f11507403efb3d9942f2f77ba3c4513e1f00f45f5341e42d1efec10f8bee1ea6c8468d050f7f7a SHA512 fd64962ade1bedaed815cc280a2e140569985c66f4ee1b282beb8c2bdeb223a64940e907376fb52c624df5f552e7e12c7845d06dafc41332091325bf58893339
diff --git a/dev-python/markdown/markdown-3.3.5.ebuild b/dev-python/markdown/markdown-3.3.5.ebuild
new file mode 100644
index 000000000000..00a2d5627863
--- /dev/null
+++ b/dev-python/markdown/markdown-3.3.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the markdown markup language"
+HOMEPAGE="
+ https://python-markdown.github.io/
+ https://pypi.org/project/Markdown/
+ https://github.com/Python-Markdown/markdown"
+SRC_URI="mirror://pypi/M/${PN^}/${P^}.tar.gz"
+S="${WORKDIR}/${P^}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="doc"
+
+BDEPEND="
+ test? (
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pytidylib[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ use doc && dodoc -r docs/
+
+ distutils-r1_python_install_all
+}