summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2024-02-16 15:14:54 -0800
committerPatrick McLean <chutzpah@gentoo.org>2024-02-16 15:15:03 -0800
commit927dab586439dbaa3d7b8fc0f61d9ee1ddf77fd0 (patch)
treeead8bdd92eb4653ba0496d9fb6f6ae20d6a69c23 /dev-python/libtmux
parentdev-dotnet/dotnet-runtime-nugets: bump to 8.0.2 (diff)
downloadgentoo-927dab586439dbaa3d7b8fc0f61d9ee1ddf77fd0.tar.gz
gentoo-927dab586439dbaa3d7b8fc0f61d9ee1ddf77fd0.tar.bz2
gentoo-927dab586439dbaa3d7b8fc0f61d9ee1ddf77fd0.zip
dev-python/libtmux: add 0.30.2
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/libtmux')
-rw-r--r--dev-python/libtmux/Manifest1
-rw-r--r--dev-python/libtmux/libtmux-0.30.2.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/libtmux/Manifest b/dev-python/libtmux/Manifest
index ba80d8c60e1f..f975cbdf3095 100644
--- a/dev-python/libtmux/Manifest
+++ b/dev-python/libtmux/Manifest
@@ -2,3 +2,4 @@ DIST libtmux-0.21.0.gh.tar.gz 267484 BLAKE2B 36d7af1bd90ff5a9639587d79f49643eec1
DIST libtmux-0.27.0.gh.tar.gz 270128 BLAKE2B 330335e24ff5f1777d3a4ebd4746adcc391919a129c08c1bfe80d7ef61e962dc550690a68055390c58e8e6c539edcac74def8646d4b1055503496ac38f72fc0d SHA512 fd847524bf6b0742bac4eca2c1032e069be09081e9107a6403eebfce0f6ca4e624f717aae0794ece54065d50cc1eb6ef48327ef1e9aea794328c42a5d7bbb293
DIST libtmux-0.28.0.gh.tar.gz 273309 BLAKE2B 9bc5b3068e64f09af0411f68f22cd23535b084175970338c827783741c8abde03548996cd573c6b58ce49298582f8e159dcab569fb6d19560229187a8da269b1 SHA512 8a6457c82cb06c72c0382c362e5d84d0a5498a01e8806adffd7e8c3a67c1b741fbd11892a3cca2156f940a954684e2d6f85ee7ad14f582f5727b977d433dd707
DIST libtmux-0.30.1.gh.tar.gz 276505 BLAKE2B 508e9b15183ecf7c3c006145fbbc9580e7180fd39b453b8a9589f644f8fddcf14144e9989c92a581c7c10a95660d9c5b9f7f5544e51e202634407c0a1914c6a2 SHA512 9ec06901f978a631b9d8085806b71912f5b582d20e917ed4409f870ec2e873095044779b1d0db2cbe0285e11a043c44cd801fa60cb2f57d9d31fb95e3015daf8
+DIST libtmux-0.30.2.gh.tar.gz 276498 BLAKE2B 13d7940d7f0f2f71819c2a5747f73fb5f0319179ec57a974461552f3de5804bc30d35c8790d8ae63bb9797b3b1aea54ab94e1f593a37cbac286b297d70d33ed0 SHA512 503dd5e7325073cc57ab9a553c3b3cf7c7cd12a506a8a59dcfd84c5902f0a1b2adab507c5b95e9abc97c9384d282bb866d8772c93b23b101d0ec8ded8f2a280d
diff --git a/dev-python/libtmux/libtmux-0.30.2.ebuild b/dev-python/libtmux/libtmux-0.30.2.ebuild
new file mode 100644
index 000000000000..3347c96865a2
--- /dev/null
+++ b/dev-python/libtmux/libtmux-0.30.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Typed library that provides an ORM wrapper for tmux, a terminal multiplexer"
+HOMEPAGE="
+ https://libtmux.git-pull.com/
+ https://github.com/tmux-python/libtmux/
+ https://pypi.org/project/libtmux/
+"
+SRC_URI="
+ https://github.com/tmux-python/libtmux/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ local issues="https://github.com/tmux-python/libtmux/issues/"
+ sed -r -i "s|:issue:\`([[:digit:]]+)\`|\`issue \1 ${issues}\1\`|" CHANGES || die
+
+ # increase timeouts for tests
+ sed -e 's/0.01/0.1/' -i tests/test_test.py || die
+
+ sed -r -e '/addopts/s:--doctest-docutils-modules::' \
+ -e '/^[[:space:]]+"README\.md"/d' \
+ -i pyproject.toml || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -a EPYTEST_DESELECT=(
+ libtmux/pane.py::libtmux.pane.Pane.send_keys
+ )
+ epytest
+}