summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-08 22:42:48 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-09 09:34:06 +0300
commita787ba66b1842334bbf9cf20ea9c27142c31fd0f (patch)
tree15cc9f28406b8c38162364a31e2aa48f0020ff7c /dev-python/leather
parentapp-xemacs/latin-unity: drop 1.20 (diff)
downloadgentoo-a787ba66b1842334bbf9cf20ea9c27142c31fd0f.tar.gz
gentoo-a787ba66b1842334bbf9cf20ea9c27142c31fd0f.tar.bz2
gentoo-a787ba66b1842334bbf9cf20ea9c27142c31fd0f.zip
dev-python/leather: add 0.3.4
- use IUSE="test" for test dependencies - remove useless sed block (those requirements files are used only for CI. - use cleaner URL to download from github Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/leather')
-rw-r--r--dev-python/leather/Manifest1
-rw-r--r--dev-python/leather/leather-0.3.4.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/leather/Manifest b/dev-python/leather/Manifest
index 1499dbaab746..c91e23b5c9f7 100644
--- a/dev-python/leather/Manifest
+++ b/dev-python/leather/Manifest
@@ -1 +1,2 @@
DIST leather-0.3.3-src.tar.gz 40522 BLAKE2B 3c7e6a48615751b310b7f066f2a78a2494e00256cae2ebfb4633c9389cca2477c2265fcf8c68f37733568ef729db1a5daf02ddc640bf2a60f2b39127c9a38d91 SHA512 30ea50ac6f97c55ee695b0e175a27e1e64fd17da7b0686ca8595fe0e5067932e19e59368fe6441f8f291ec52be3e597a80f8e04a3fcc0eeae33b3a5b3030e1d6
+DIST leather-0.3.4.gh.tar.gz 41368 BLAKE2B a1181da5904234677290134726da33a71e0f37e6f0161beb0ec7a73efca1b2b26e973221f2f42b72fd2640ef503a8adc905273885deef212ee9d1aae6d91f804 SHA512 0547adf5d455afe9397cf9c597cc7edbcdbe25bb56e32d764c67119bfe1329d959834f2a41720adb51ec926065e044feb27f7a5e3f800c8636a22d4f96752212
diff --git a/dev-python/leather/leather-0.3.4.ebuild b/dev-python/leather/leather-0.3.4.ebuild
new file mode 100644
index 000000000000..0b16ba2fc747
--- /dev/null
+++ b/dev-python/leather/leather-0.3.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python charting for 80% of humans"
+HOMEPAGE="https://github.com/wireservice/leather https://pypi.org/project/leather/"
+SRC_URI="https://github.com/wireservice/leather/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="test? ( dev-python/lxml[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme