summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-08-16 08:50:38 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-08-16 09:26:16 +0300
commit9ee928a642975d7e01ea3ac48c2c7f37ff43f962 (patch)
tree0f1b31ca250a2dda6e2b5931d127679a621fef3e /dev-python/jc
parentdev-python/pytest-rerunfailures: Remove old (diff)
downloadgentoo-9ee928a642975d7e01ea3ac48c2c7f37ff43f962.tar.gz
gentoo-9ee928a642975d7e01ea3ac48c2c7f37ff43f962.tar.bz2
gentoo-9ee928a642975d7e01ea3ac48c2c7f37ff43f962.zip
dev-python/jc: remove redundant sed, update HOMEPAGE
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/jc')
-rw-r--r--dev-python/jc/jc-1.16.0.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/dev-python/jc/jc-1.16.0.ebuild b/dev-python/jc/jc-1.16.0.ebuild
index f1821811b60b..55a2e83ea478 100644
--- a/dev-python/jc/jc-1.16.0.ebuild
+++ b/dev-python/jc/jc-1.16.0.ebuild
@@ -8,8 +8,11 @@ PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Converts the output of popular command-line tools and file-types to JSON"
-HOMEPAGE="https://github.com/kellyjonbrazil/jc/tags"
-SRC_URI="https://github.com/kellyjonbrazil/jc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/kellyjonbrazil/jc"
+SRC_URI="
+ https://github.com/kellyjonbrazil/jc/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
LICENSE="MIT"
SLOT="0"
@@ -20,8 +23,3 @@ RDEPEND="dev-python/pygments[${PYTHON_USEDEP}]
dev-python/xmltodict[${PYTHON_USEDEP}]"
distutils_enable_tests unittest
-
-python_prepare_all() {
- sed -e "s|\\(^[[:space:]]*'[.[:alnum:]]\+\\)>=[^']*|\\1|" -i setup.py || die
- distutils-r1_python_prepare_all
-}