summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2016-12-11 19:39:56 +0100
committerMichał Górny <mgorny@gentoo.org>2016-12-11 22:31:09 +0100
commitb894a191be4749db8fbafb7cc97bc72633f5d5f7 (patch)
tree55432a7abd6949376b4f7cd46b7331d7084e8dee /dev-python/imageio/imageio-2.0.1.ebuild
parentnet-dialup/rp-pppoe: Revbump to fix path to ifconfig (bug #602344). (diff)
downloadgentoo-b894a191be4749db8fbafb7cc97bc72633f5d5f7.tar.gz
gentoo-b894a191be4749db8fbafb7cc97bc72633f5d5f7.tar.bz2
gentoo-b894a191be4749db8fbafb7cc97bc72633f5d5f7.zip
dev-python/imageio: version bump
Closes: https://github.com/gentoo/gentoo/pull/3089 Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-python/imageio/imageio-2.0.1.ebuild')
-rw-r--r--dev-python/imageio/imageio-2.0.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/imageio/imageio-2.0.1.ebuild b/dev-python/imageio/imageio-2.0.1.ebuild
new file mode 100644
index 000000000000..07d0d943e8df
--- /dev/null
+++ b/dev-python/imageio/imageio-2.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for reading and writing image data"
+HOMEPAGE="https://imageio.github.io/"
+SRC_URI="https://github.com/imageio/imageio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ media-libs/freeimage
+ "
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "