summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-06 17:35:57 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-06 18:17:04 +0200
commit4a8a843b8bb2d424f728b3b009a8825201a6e7fa (patch)
treea6a5deb171d038afbda1c908c310fdc019058db0 /dev-python/ijson
parentdev-python/mkdocs-material: Bump to 9.5.26 (diff)
downloadgentoo-4a8a843b8bb2d424f728b3b009a8825201a6e7fa.tar.gz
gentoo-4a8a843b8bb2d424f728b3b009a8825201a6e7fa.tar.bz2
gentoo-4a8a843b8bb2d424f728b3b009a8825201a6e7fa.zip
dev-python/ijson: Bump to 3.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ijson')
-rw-r--r--dev-python/ijson/Manifest1
-rw-r--r--dev-python/ijson/ijson-3.3.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/ijson/Manifest b/dev-python/ijson/Manifest
index 088eea6410ef..ba569433523e 100644
--- a/dev-python/ijson/Manifest
+++ b/dev-python/ijson/Manifest
@@ -1 +1,2 @@
DIST ijson-3.2.3.tar.gz 57596 BLAKE2B e85465829f8319e2e227b7b72633b65e7e77a8cd24fee877aded1f50383ffbbaddd82e5e3942c0b3f637a8e601c5101aa390889e8509ee2c61b6f3c9cf9a7249 SHA512 ca72ed08c7804611d7f9c5218d217087fe17358859d080741726b42072df1407afcf1f701e30d33f3f615e8c78ba247a3cc45e8e7e373f1d3168a63f397fd6eb
+DIST ijson-3.3.0.tar.gz 60079 BLAKE2B 53c92015c30ed285acec1f9e811521eeb9d22b2011b0398b23e44c1b0fff2b97e87b48b9058733db6002222913ebeb1a304763e7c5f8fe6c2d872f791d80ce39 SHA512 9517919b98904608f81ee0292968e9c8951e3e96cdec286d945eebcd94ae6322c08a878ebfabce3e226646bf04488710274563b1f48048707bc78e51941b5d23
diff --git a/dev-python/ijson/ijson-3.3.0.ebuild b/dev-python/ijson/ijson-3.3.0.ebuild
new file mode 100644
index 000000000000..76f9f9930981
--- /dev/null
+++ b/dev-python/ijson/ijson-3.3.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Iterative JSON parser with a Pythonic interface"
+HOMEPAGE="
+ https://github.com/ICRAR/ijson/
+ https://pypi.org/project/ijson/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+DEPEND="
+ dev-libs/yajl:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests pytest
+
+export IJSON_BUILD_YAJL2C=1
+
+python_test() {
+ rm -rf ijson || die
+ epytest
+}