summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-04 08:27:08 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-04 08:49:26 +0200
commit024460675a7c1d955e7e630abddbb92152a3306e (patch)
tree98b170c9f55ff4d33d5aa1e1eb8aca79fcaafc61 /dev-python/griffe
parentdev-libs/libclc: Add 17.0.0_pre20230602 snapshot (diff)
downloadgentoo-024460675a7c1d955e7e630abddbb92152a3306e.tar.gz
gentoo-024460675a7c1d955e7e630abddbb92152a3306e.tar.bz2
gentoo-024460675a7c1d955e7e630abddbb92152a3306e.zip
dev-python/griffe: Bump to 0.29.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/griffe')
-rw-r--r--dev-python/griffe/Manifest1
-rw-r--r--dev-python/griffe/griffe-0.29.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/griffe/Manifest b/dev-python/griffe/Manifest
index 6e0e2a6231c0..7bfdc5a401fa 100644
--- a/dev-python/griffe/Manifest
+++ b/dev-python/griffe/Manifest
@@ -1,2 +1,3 @@
DIST griffe-0.27.4.gh.tar.gz 154404 BLAKE2B 40c3a67b47561eeaf846a53ee678e3473a4064ab58c1a07b823b914e2fcfda15e43de9dc6bac074eeb238838d27a9c14f4314a481590c83df1e83dcce320525f SHA512 bb927d956b289048950343d087da5be057fbef8e38feff345ce5f46ca1edfeb87a6fe94b8be18d7c76beef84c69dc97a3972177aac69429a4633f1543906b8e5
DIST griffe-0.28.2.gh.tar.gz 157261 BLAKE2B 284e63ffcb507233b5965b6e3931036703c9577c7e34149a27f24ffbd54f48f11ed873c690b931886fc043848cfca71c6d94638f0c1073428a1df17f04a33b58 SHA512 8c79fc3a0126cb34f7b13d7407aee5f63c926564da03cf13c5a053b79e3cd736d609f88bb83142ba9baf1fac00e3c8a392ee19c72fa6b0f32a4b383183f5a828
+DIST griffe-0.29.0.gh.tar.gz 157523 BLAKE2B 2854d6e30898e7aec9b6481215311956bcd9b24eb4b7cb36c11515f36a90467cabfc2cf9320bf4dcb44f04d8dd855cde97a749f7b51529cbfe5bd5e8e4391d9c SHA512 3367e48ac9337d180621fa694babc61dec445cc86b1555a65d14547c95aabda637ef72d86d3a1eb16fc736923876cda6c2ba51fa346551e5e134b490557d1459
diff --git a/dev-python/griffe/griffe-0.29.0.ebuild b/dev-python/griffe/griffe-0.29.0.ebuild
new file mode 100644
index 000000000000..61ce95ac1b11
--- /dev/null
+++ b/dev-python/griffe/griffe-0.29.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Signature generator for Python programs"
+HOMEPAGE="
+ https://mkdocstrings.github.io/griffe/
+ https://github.com/mkdocstrings/griffe/
+ https://pypi.org/project/griffe/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/griffe/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/colorama-0.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/jsonschema-4.17.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}