summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-06 20:07:21 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-06 20:08:45 +0200
commit30bc86bcb30d019ee99fa79e2c110f9210f50c2f (patch)
treec0c78775845f7804296a5cf39ad3a3b339935dd7 /dev-python/gpep517
parentnet-dialup/freeradius: Fix typo in ebuild (diff)
downloadgentoo-30bc86bcb30d019ee99fa79e2c110f9210f50c2f.tar.gz
gentoo-30bc86bcb30d019ee99fa79e2c110f9210f50c2f.tar.bz2
gentoo-30bc86bcb30d019ee99fa79e2c110f9210f50c2f.zip
dev-python/gpep517: Remove broken v4
This version breaks opening existing zip files (e.g. eggs found in sys.path). Closes: https://bugs.gentoo.org/842627 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/gpep517')
-rw-r--r--dev-python/gpep517/Manifest1
-rw-r--r--dev-python/gpep517/gpep517-4.ebuild44
2 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/gpep517/Manifest b/dev-python/gpep517/Manifest
index 17164539b9c0..08e43bf6a1c1 100644
--- a/dev-python/gpep517/Manifest
+++ b/dev-python/gpep517/Manifest
@@ -1,2 +1 @@
DIST gpep517-3.gh.tar.gz 7074 BLAKE2B 99a499ae13b6aac41e86d11735f0e49a5dc921881a1efa94bee19bfd779af6827707d05d6407ed15e4a3a6b518c8c0b3f50901e3b12df41081930f83b288e461 SHA512 90f756f5a1d783e9d402e098162a70b363a0a81e331e810e5c89c3302bb5839032603252bad1c98c176a7828b70adfac967e39ba455dcd3a20097e74923980c8
-DIST gpep517-4.gh.tar.gz 8950 BLAKE2B ce5d74ee8bda415f14959a8d35561034f99f2f6be373e8ac937cb95e1109878eec63d171236c45ad86ba41db847194bb846ed3226511c579bb156d112146b294 SHA512 74de4318a86fe4282ad6fff4dd9aedc491aced1df4705e62484160edc0c7d447b035cd0ee915a3766bcb3cede95c2ee4dc26064336a56f5763566c79d8b8156e
diff --git a/dev-python/gpep517/gpep517-4.ebuild b/dev-python/gpep517/gpep517-4.ebuild
deleted file mode 100644
index 823987f2f511..000000000000
--- a/dev-python/gpep517/gpep517-4.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=manual
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="A backend script to aid installing Python packages in Gentoo"
-HOMEPAGE="
- https://pypi.org/project/gpep517/
- https://github.com/mgorny/gpep517/
-"
-SRC_URI="
- https://github.com/mgorny/gpep517/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-RDEPEND="
- >=dev-python/installer-0.5.0[${PYTHON_USEDEP}]
- >=dev-python/tomli-1.2.3[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-# do not use any build system to avoid circular deps
-python_compile() { :; }
-
-python_install() {
- python_domodule gpep517
- python_newscript - gpep517 <<-EOF
- #!${EPREFIX}/usr/bin/python
- import sys
- from gpep517.__main__ import main
- sys.exit(main())
- EOF
-}