summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-18 08:42:18 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-18 08:56:36 +0200
commit8c0fc2df49027ccb894292873eff80e5b1b6dc2c (patch)
tree21215312e6d2b08006dc599041cb4d72c39068f5 /dev-python/google-auth
parentdev-python/google-api-python-client: Bump to 2.17.0 (diff)
downloadgentoo-8c0fc2df49027ccb894292873eff80e5b1b6dc2c.tar.gz
gentoo-8c0fc2df49027ccb894292873eff80e5b1b6dc2c.tar.bz2
gentoo-8c0fc2df49027ccb894292873eff80e5b1b6dc2c.zip
dev-python/google-auth: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-2.0.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index 2eb98eb83941..4ff5d583d2b5 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,3 +1,4 @@
DIST google-auth-1.32.1.tar.gz 171621 BLAKE2B e82f4666a38d3dbaa4aa4a4d5192afb711471432c0dcca44b1a1c52fa2171f1de0d7ffd8a7a6d5dc6dbc3a1dec16becabb26306a9ba3b3fd0998584dd1194cc6 SHA512 968c16c7fc5c8c589a94e24139c319ec7f2791b021d6240156d398d4795e6afee8e46591c4aa44457de6f98ca14e8edcb055fb3a02914b43ba5fab74a03d9fc6
DIST google-auth-1.34.0.tar.gz 180860 BLAKE2B d536d689ff5b0c033f787228d643504d1888f0b73a9c6855fe4fae3af20772ef0640feca39c58c39f45681561dce6d5f3ec1d1f7d9699442fff0ec63fd019361 SHA512 7c3b64e8f85056fb660bbfd4f737053813a1e5b8aba52290882a0ddb9d9fd8c5365b767c78dd1e7859ef95caa6e653786d5a8747c8792bbee9c6fad1a5218910
DIST google-auth-1.35.0.tar.gz 181504 BLAKE2B 3994650c1931f98bebe3299a61660462370c81db4f281bf67db5fc41ec8964a50b7cde1a72b9c8d34a9220a9f6018608b83705cb6e853cd1797740b569023555 SHA512 7dcaa202b36e18679ea85ffbb1fdb204f1a5b28eabf158dbde96e1a783b034bf424b801ba63609678bb275a2bbf92aedf019e6dec06fc90f5968e3d5d41191f0
+DIST google-auth-2.0.0.tar.gz 180337 BLAKE2B e262ba19e41a8216c8ccc7f50ce9beb25764809853e9dc49900c7edacee4adfe255d307a503768ed257f9843ded01620aeff89e4cf0e9abf8e987e75f0eef8a5 SHA512 21f7adfd07ef5abe2dc2da9fb2b5c660157be6645b039510e14e3f80f6e39561f2a679c7e948d14ca96173da87c920adbfaaeb4c4877e8504bec638b318528cd
diff --git a/dev-python/google-auth/google-auth-2.0.0.ebuild b/dev-python/google-auth/google-auth-2.0.0.ebuild
new file mode 100644
index 000000000000..cd44f928efdd
--- /dev/null
+++ b/dev-python/google-auth/google-auth-2.0.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/cachetools-2.0.0[${PYTHON_USEDEP}]
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}