summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-08 15:10:55 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-08 15:17:49 +0100
commit841ba8ac8a9990aa45e209c328f369c251fb8939 (patch)
treecdd4b2b448b9cfccb9273531615241b78b2816d8 /dev-python/google-auth-oauthlib
parentdev-python/google-auth-httplib2: Remove Python < 3.10 (diff)
downloadgentoo-841ba8ac8a9990aa45e209c328f369c251fb8939.tar.gz
gentoo-841ba8ac8a9990aa45e209c328f369c251fb8939.tar.bz2
gentoo-841ba8ac8a9990aa45e209c328f369c251fb8939.zip
dev-python/google-auth-oauthlib: Remove Python < 3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-auth-oauthlib')
-rw-r--r--dev-python/google-auth-oauthlib/google-auth-oauthlib-0.8.0-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.8.0-r2.ebuild b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.8.0-r2.ebuild
new file mode 100644
index 000000000000..428011855aa4
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.8.0-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=google-auth-library-python-oauthlib-${PV}
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/
+ https://pypi.org/project/google-auth-oauthlib/
+"
+SRC_URI="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.7.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest