summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2016-06-25 00:21:23 +0200
committerDavid Seifert <soap@gentoo.org>2016-07-02 14:35:33 +0200
commit67c31457f0cf39c67ef380176e0c87b0d5fc778f (patch)
tree90505a4173101374f1abe084215e796f148a5557 /dev-python/git-python
parentapp-arch/patool: new package (diff)
downloadgentoo-67c31457f0cf39c67ef380176e0c87b0d5fc778f.tar.gz
gentoo-67c31457f0cf39c67ef380176e0c87b0d5fc778f.tar.bz2
gentoo-67c31457f0cf39c67ef380176e0c87b0d5fc778f.zip
dev-python/git-python: version bump
Package-Manager: portage-2.3.0_rc1 Closes: https://github.com/gentoo/gentoo/pull/1740 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/git-python')
-rw-r--r--dev-python/git-python/Manifest1
-rw-r--r--dev-python/git-python/git-python-2.0.5.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/git-python/Manifest b/dev-python/git-python/Manifest
index c84a3dd5ac0e..f52ca58c6df8 100644
--- a/dev-python/git-python/Manifest
+++ b/dev-python/git-python/Manifest
@@ -2,3 +2,4 @@ DIST GitPython-0.3.6.tar.gz 353639 SHA256 f3f42ca085eedbd3a9956b5e639de58bbe77a1
DIST GitPython-1.0.0.tar.gz 354662 SHA256 c1b3e6fdd209040b6b1cb32ecbff989eeb2fb31b4e7078c3342d71ae8ef7352b SHA512 02d6ca44c930cabd9aa7344ae2f97d201e1840cf22b6083e949f9f374113558b1d7ca88f2d5a4691e63d71da5e54418ef7b8807adb2dfcf90d843fe2d588b3f9 WHIRLPOOL 1623ffabe1bd9de7a71890e3794b45b5871ef519d2b7581f881b4df4e54dc529e5e75bd7835161900a4307ffabfa014f7e64dbe1cee9502b70821691c9853476
DIST GitPython-1.0.1.tar.gz 355108 SHA256 9c88c17bbcae2a445ff64024ef13526224f70e35e38c33416be5ceb56ca7f760 SHA512 63fc061f0e045b11adf20ab291f9d614028d76fb44c6b0910193f6a9f4a5f9bae070527fa2ca06b234da12b7cd545194a7f5e912f4e09370bd41f81552c3160f WHIRLPOOL f166834a746d5e2a4888219aa86f897f2713dbcc94dd1f2444a3ffc1b292bb2ae0b83df51aebd65ef45b942ff6d48ebb08b26796818512af6fcafded90398d4e
DIST GitPython-1.0.2.tar.gz 387615 SHA256 85de72556781480a38897a77de5b458ae3838b0fd589593679a1b5f34d181d84 SHA512 faff50d5272158f1d05d932e7827c05272f9a28772aabbcabd631b735bb4d8306d2861d13c327d02a4c554bd9a9902c473fb282318036405497dd8bf0fcc51a8 WHIRLPOOL c12e850114d101faa673d4d87e6885b1d7cd55544d335e08d4579c160e4d8ef488dd09359cfbd9a39e11f4555b8cb3cd2bfec214c95883b5a83565ad1e28b403
+DIST GitPython-2.0.5.tar.gz 404610 SHA256 20f3c90fb8a11edc52d363364fb0a116a410c7b7bdee24a433712b5413d1028e SHA512 7e01f2dcc91b736baae42ebe5be10a001501392d6309e2aea346f411f8c38ea5b10b159664260d9014e2e2b3fec97dfe061e7c72ec6575ac4f8d0cf2da022305 WHIRLPOOL 316df97e75b273f14b78ce6d69418dfe77d8108f1cffc638e44f9e3c6f571feeec295781c0193f8976b9a2a57ceb540320fde386036a2a71c51fb5312ec56ec0
diff --git a/dev-python/git-python/git-python-2.0.5.ebuild b/dev-python/git-python/git-python-2.0.5.ebuild
new file mode 100644
index 000000000000..74adc5c4efe6
--- /dev/null
+++ b/dev-python/git-python/git-python-2.0.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+MY_PN="GitPython"
+MY_PV="${PV/_rc/.RC}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Library used to interact with Git repositories"
+HOMEPAGE="http://gitorious.org/git-python https://pypi.python.org/pypi/GitPython"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# Tests dont make sense without a git repo
+RESTRICT="test"
+
+RDEPEND="
+ dev-vcs/git
+ >=dev-python/gitdb-0.6.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+# $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+# is the correct entry for mock, however while RESTRICT="test"
+# there is little point in setting it since it is inactive
+S="${WORKDIR}/${MY_P}"