summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-07 15:30:10 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-07 16:10:34 +0200
commit5e31ff8135b23aec6884c40d4cc99b8c30b02182 (patch)
treebdf70a4037d7ba2fd325c5642233d3c503ada350 /dev-python/furo
parentdev-python/time-machine: Bump to 2.15.0 (diff)
downloadgentoo-5e31ff8135b23aec6884c40d4cc99b8c30b02182.tar.gz
gentoo-5e31ff8135b23aec6884c40d4cc99b8c30b02182.tar.bz2
gentoo-5e31ff8135b23aec6884c40d4cc99b8c30b02182.zip
dev-python/furo: Bump to 2024.8.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/furo')
-rw-r--r--dev-python/furo/Manifest1
-rw-r--r--dev-python/furo/furo-2024.8.6.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/furo/Manifest b/dev-python/furo/Manifest
index fce510de5fb0..56a23a10e154 100644
--- a/dev-python/furo/Manifest
+++ b/dev-python/furo/Manifest
@@ -1 +1,2 @@
DIST furo-2024.7.18-py3-none-any.whl 340824 BLAKE2B 619e7183541921ec31f5a7e7ebcbc86f0507e04bf7e5c9e308a3b6a6b580cf734fe46b641b3bcaaeeaba39516ca27b49ef8faadd0d9d5864343aafc15a05037d SHA512 62c047742a0a851e5faf56013751d05a411920ca7659ef42fc06bcce6766a6605734b370a636f4b1c2805def42881c273a2b5eb6704484571d76a44145b0a346
+DIST furo-2024.8.6-py3-none-any.whl 341333 BLAKE2B e0cf87a69b35a0a48eb54eb9530ec92f5fa06882b4c4a9bf306a3b1eee7af8510e37dfd1b612fe747856e48eada1eed05ae8e5e270616bf9b5fd5a70705a9c53 SHA512 e9e32eb26659b710836c86bd881c07625d14a10000674d488da2dc71e5cbb7ba6ce4494892f731dbcf288af11bcf6870f9f97f70364425cca4a00f7edda01d48
diff --git a/dev-python/furo/furo-2024.8.6.ebuild b/dev-python/furo/furo-2024.8.6.ebuild
new file mode 100644
index 000000000000..9afc06b408f3
--- /dev/null
+++ b/dev-python/furo/furo-2024.8.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# sphinx-theme-builder is completely unusable, as it requires pinning
+# to a very-specific nodejs version number, and ofc loves fetching
+# everything from the Internet
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Clean customisable Sphinx documentation theme"
+HOMEPAGE="
+ https://pypi.org/project/furo/
+ https://github.com/pradyunsg/furo/
+"
+SRC_URI="$(pypi_wheel_url)"
+S=${WORKDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-basic-ng[${PYTHON_USEDEP}]
+"
+
+src_unpack() {
+ if [[ ${PKGBUMPING} == ${PVR} ]]; then
+ unzip "${DISTDIR}/${A}" || die
+ fi
+}
+
+python_compile() {
+ distutils_wheel_install "${BUILD_DIR}/install" \
+ "${DISTDIR}/${P}-py3-none-any.whl"
+}