summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/foolscap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/foolscap')
-rw-r--r--dev-python/foolscap/Manifest3
-rw-r--r--dev-python/foolscap/foolscap-0.6.4-r1.ebuild38
-rw-r--r--dev-python/foolscap/foolscap-0.7.0.ebuild37
-rw-r--r--dev-python/foolscap/foolscap-0.8.0.ebuild56
-rw-r--r--dev-python/foolscap/metadata.xml25
5 files changed, 159 insertions, 0 deletions
diff --git a/dev-python/foolscap/Manifest b/dev-python/foolscap/Manifest
new file mode 100644
index 000000000000..6f89300b4f37
--- /dev/null
+++ b/dev-python/foolscap/Manifest
@@ -0,0 +1,3 @@
+DIST foolscap-0.6.4.tar.gz 479664 SHA256 74b283dd68a3c9d68ebf4e9b4ebf5cfb37480915b6a808ac930fe858a66f8d99 SHA512 014ec256b6192b509bebaef4d716f0d57c78062ae92621567d6be29b9f4cfad431cf691bb13b361f5eb1e383f62c5c164821154b35d2a06081369a175835012e WHIRLPOOL f1254636e9f668a669e14098490147143a723360a291320e6bc7ce8914b2049c024760dede4f5eec01bd4d4be0c709d7a4fd56d1e61f376a40f63942cbb27356
+DIST foolscap-0.7.0.tar.gz 478999 SHA256 fba0e016079442c9e69e2752727a1307f4110a1c62319a059650b2ab044b29d8 SHA512 b2eb5415376d4e8e4ee3fd9ecef80a02d195d6b44059e5292c2daa7dcfdea9deafd8678ff89391128244a8d41fb6a69a92f9e4f07cc599f7358783dc8cb70f15 WHIRLPOOL 58bc4b34d36e1edfa3bbcadb6a16704820af8b6448bf09d6d5e95c23edf60f41481d6792fcae808c0bd8bb3f71b18ed794c0be00e77cc67f160cb3b026567384
+DIST foolscap-0.8.0.tar.gz 475062 SHA256 6ab49e8c52ee49597148802a877593ddb6ca9a63cb32eaae8bff2900667be1c9 SHA512 4f491ac1e35e76b7fcee5994312e34696921eb7a9b0913e919142fe2807e32aad5ddbbffec3bfe5e1f4333ec38e0ee607ea9cfe5007b385ab6a15ea913c80f45 WHIRLPOOL 5b8c26eb081cf211683d6a8ed3177267793fe2aa3258b2e6b381aaa4d367ae4c0fb61b0902a186874efad9d2150303378d4468c573992047ac0994998ba2f534
diff --git a/dev-python/foolscap/foolscap-0.6.4-r1.ebuild b/dev-python/foolscap/foolscap-0.6.4-r1.ebuild
new file mode 100644
index 000000000000..acb53bf367ae
--- /dev/null
+++ b/dev-python/foolscap/foolscap-0.6.4-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="RPC protocol for Twisted"
+HOMEPAGE="http://foolscap.lothar.com/trac http://pypi.python.org/pypi/foolscap"
+SRC_URI="http://${PN}.lothar.com/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc ssl"
+
+RDEPEND=">=dev-python/twisted-core-2.4.0[${PYTHON_USEDEP}]
+ dev-python/twisted-web[${PYTHON_USEDEP}]
+ ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )"
+DEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ local -x LC_ALL=C
+ trial ${PN} || die "Tests fail for ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dodoc doc/*.txt
+ dohtml -A py,tpl,xhtml -r doc/*
+ fi
+}
diff --git a/dev-python/foolscap/foolscap-0.7.0.ebuild b/dev-python/foolscap/foolscap-0.7.0.ebuild
new file mode 100644
index 000000000000..f400ed6bed4b
--- /dev/null
+++ b/dev-python/foolscap/foolscap-0.7.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="RPC protocol for Twisted"
+HOMEPAGE="http://foolscap.lothar.com/trac http://pypi.python.org/pypi/foolscap"
+SRC_URI="http://${PN}.lothar.com/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc +ssl test"
+
+RDEPEND=">=dev-python/twisted-core-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-web-2.5.0[${PYTHON_USEDEP}]
+ ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+python_test() {
+ trial ${PN} || die "Tests fail for ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dodoc doc/*.txt
+ dohtml -A py,tpl,xhtml -r doc/*
+ fi
+}
diff --git a/dev-python/foolscap/foolscap-0.8.0.ebuild b/dev-python/foolscap/foolscap-0.8.0.ebuild
new file mode 100644
index 000000000000..0b182db8daa7
--- /dev/null
+++ b/dev-python/foolscap/foolscap-0.8.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="RPC protocol for Twisted"
+HOMEPAGE="http://foolscap.lothar.com/trac http://pypi.python.org/pypi/foolscap"
+SRC_URI="http://${PN}.lothar.com/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc +ssl test"
+
+# setup.py stipulates >=twisted-core-2.5.0 but failures occur in testsuite under -15.x
+RDEPEND="
+ >=dev-python/twisted-core-2.5.0[${PYTHON_USEDEP}]
+ <dev-python/twisted-core-15.0.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-web-2.5.0[${PYTHON_USEDEP}]
+ <dev-python/twisted-web-15.0.0[${PYTHON_USEDEP}]
+ dev-python/service_identity[${PYTHON_USEDEP}]
+ ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
+ "
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+python_test() {
+ trial ${PN} || die "Tests fail for ${EPYTHON}"
+}
+
+python_compile_all() {
+ local i;
+ if use doc; then
+ pushd doc > /dev/null
+ mkdir build || die
+ for i in ./*.rst
+ do
+ rst2html.py $i > ./build/${i/rst/html} || die
+ done
+ popd > /dev/null
+ fi
+}
+
+python_test() {
+ trial ${PN} || die "Tests fail for ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/foolscap/metadata.xml b/dev-python/foolscap/metadata.xml
new file mode 100644
index 000000000000..de8f9439ef0a
--- /dev/null
+++ b/dev-python/foolscap/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+<longdescription>
+This is a ground-up rewrite of Perspective Broker, which itself is Twisted's
+native RPC/RMI protocol (Remote Procedure Call / Remote Method Invocation).
+If you have control of both ends of the wire, and are thus not constrained to
+use some other protocol like HTTP/XMLRPC/CORBA/etc, you might consider using
+Foolscap.
+
+Fundamentally, Foolscap allows you to make a python object in one process
+available to code in other processes, which means you can invoke its methods
+remotely. This includes a data serialization layer to convey the object
+graphs for the arguments and the eventual response, and an object reference
+system to keep track of which objects you are connecting to. It uses a
+capability-based security model, such that once you create a non-public
+object, it is only accessible to clients to whom you've given the
+(unguessable) FURL. You can of course publish world-visible objects that
+have well-known FURLs.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">foolscap</remote-id>
+ </upstream>
+</pkgmetadata>