summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-08 19:04:27 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-08 19:47:54 +0200
commit51506516f5bdb8389f63dea734b836b46a5e56ee (patch)
tree2c1ea319168a4b7a2e496184fb3e21939b5e2948 /dev-python/flask-paginate
parentdev-python/websocket-client: Bump to 1.6.4 (diff)
downloadgentoo-51506516f5bdb8389f63dea734b836b46a5e56ee.tar.gz
gentoo-51506516f5bdb8389f63dea734b836b46a5e56ee.tar.bz2
gentoo-51506516f5bdb8389f63dea734b836b46a5e56ee.zip
dev-python/flask-paginate: Bump to 2023.10.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-paginate')
-rw-r--r--dev-python/flask-paginate/Manifest1
-rw-r--r--dev-python/flask-paginate/flask-paginate-2023.10.8.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/flask-paginate/Manifest b/dev-python/flask-paginate/Manifest
index 60e9ebf0e3fe..817dc55544c7 100644
--- a/dev-python/flask-paginate/Manifest
+++ b/dev-python/flask-paginate/Manifest
@@ -1 +1,2 @@
DIST flask-paginate-2022.1.8.gh.tar.gz 120847 BLAKE2B 110d6f7bb6c244378a41ab26c914898b54fb05cc00cfc6c7c3e15ed96e2163f92cc89c4ce93199091d8ed2f52301e997ebc16a71a3d802b8107249f9f832ca25 SHA512 9f2e0e50d73ac15ec2a413671a52e9dbbbb7eac8576494483441ea1287a12e2076cf649ee9df0bf3b3d2c7e13eebe4a835031ab57a2e8b2015f383d53318a0b9
+DIST flask-paginate-2023.10.8.gh.tar.gz 120855 BLAKE2B c872cb635220b92c7fab5a997d8eb90c30fd5036acab81cc72ca9f5381f370faabb8a4d641b34c73f595e8b6f4a10bedbc1650a5bd57df292fcfd6a267cfc64c SHA512 4071fefe44cf0474e9b5716976d163449145f3ba4276e5d467bb513e1be371e044096d222e3f19b228041863f4f0136a1838c4d066a890c8c21359d17e674596
diff --git a/dev-python/flask-paginate/flask-paginate-2023.10.8.ebuild b/dev-python/flask-paginate/flask-paginate-2023.10.8.ebuild
new file mode 100644
index 000000000000..545297259bb7
--- /dev/null
+++ b/dev-python/flask-paginate/flask-paginate-2023.10.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pagination support for flask"
+HOMEPAGE="
+ https://flask-paginate.readthedocs.io/
+ https://github.com/lixxu/flask-paginate/
+ https://pypi.org/project/flask-paginate/
+"
+SRC_URI="
+ https://github.com/lixxu/flask-paginate/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests/tests.py
+}